Anybody having trouble pulling FCBH audio files from the cloud using DBP4 keys?

I’m hoping someone knows the trick here, but we are having no success in using our new DBP4 key, to download the online audio files from FCBH. NOTE: the DBP4 key works, and the Test button even verifies the MP3 and WebM files are OK. (And using it to query the repository using a browser URL also pulls the correct information.)

When we run the built app, it asks if we want to download the file from the internet. We say yes, it opens the “Downloading…” dialog, but shortly thereafter it fails with a “Check the internet connection.” (Which is not the problem.)

It acts the same way whether the app was installed from an APK stored on internal memory or on a microSD card.

In previous app versions, we had no trouble with the DBP2 key failing like this. It just worked.

BTW, the DPB4 key works for the videos just fine.

So, why not just use the DBP2 key, you ask? Well, we hear everything is moving over to the DBP4, and our key has been migrated too. So, shouldn’t it just work?

Thanks for any help here.

Hello David,

Can you share your project with me (via Dropbox, Google Drive or Scriptoria Project #)? My email is chris underscore hubbard at sil dot org.

Thanks,
Chris

FYI, there was a problem earlier this week where there was a misconfiguration of the DBP4 server. That was fixed. When was the last time that you tried using the app to access audio from DBP4?

Thanks,
Chris

David,

I have had the same problem. I was experimenting with try to download WebM files from the DBP4. The key checks out OK and the Test button verifies, but when I try to download the audio I get the same error message as you.

Just now. I just rebuilt two of the apps. And the download says “Check internet connection” after it shows the “Downloading…” progress dialog.

I just tried the lastest SAB (v9.1.1), and it solves getting the v2 audio files using the v4 key. But it does NOT solve the problem where the audio files are ONLY on the new v4 server. In this case SAB apps still say the audio information passes the Test button, but the apps fail to download the audio files from the v4 server (using the v4 key). As I understand it, this is a problem with the SAB still building v2 APIs into the apps, rather than building the v4 APIs into the apps. (I’m a raw novice on this, but this is what I gleaned from a discussion on this problem we are having.) I had hoped v9.1.1 was the solution, but that hopefully will come in the next build?

@david_coward, using v4 APIs to download audio are on the list to implement. I am not certain when it will be completed.

Good to know it is on the list.
Because it sounds like FCBH is moving quickly with the conversion to the new server, and any new recording will be unavailable to its SAB app until these APIs are put into the SAB process.

We are hoping you all are given the thumbs up to treat this upgrade as a pretty high priority. And praying the conversion is clean and simple, and does not introduce unintended consequences! Blessings be on the developers!

@david_coward I will try to get to it soon. I have a few issues ahead of it.

Oh! Cool. Thanks for that info. And we can pray for you specifically, Chris.

@ChrisHubbard - I heard from several of our partners that they are facing the same issue when trying to download audio (using Bible Brain as Audio Source) in SAB 9.1.1. (@Dan_Neville, @BrianA, @Matt_A, @Jayak_NLCI - I am assuming you are facing this same issue).

Yes. I’m having a similar issue. For me, the app builds fine, but when I press play for the audio, nothing happens. I have never seen the “Check internet connection” message, though – it just does nothing.

@jkurian - Yes, I is one of the projects that I am working on. DBP4 supports the older DBP2 APIs. I guess I assumed that new content would still be available through the older DBP2 APIs (that is normally how backwards compatibility works). It isn’t. So we are scrambling. I am dealing with other issues so unfortunately it is not the highest priority.

FCBH asked me to test if .webm files now download ok. They do! I just needed to change to Fileset ID: NODWBTN1DA-opus16. Their webm files have the -opus16 suffix. They may have made some additional changes.

I also noticed that webm files downloaded from FCBH fastforward and rewind correctly using the single and double arrows. I deleted the webm files I created with latest SAB/FFMEG converter that would not forward or rewind correctly, and substituted the files downloaded from FCBH and they work perfect in the App,

If you want webm and your audio is in FCBH Bible Brain you might try building a new app with the fileset set to “Fileset ID”-opus16 . You can download, stream or package these webm files in your app.

Roger,

Can you give more detail about how you are getting this to work? I’ve tried a few different times and keep getting an error message “Download error: please check your Internet connection.” I have changed by Fileset ID to add the “-opus16” ending. What do your audio filenames look like?

I’ve been trying to use filenames that look like this:
B03___20_San_Lucas___AZGTBLN1DA.webm

Do the filenames need to include the “-opus16” ending as well?

Thanks,
David Fetrow

Just wanted to let folk know that without changing anything in my app, the download audio process now works. So, an app which uses the new v4 key, and which has its FCBH audio files only on the new FCBH server, now works for pulling those audio files down to the phone and playing them! Woo-hoo! Well done, Chris. Thanks.

David, Have you made any progress making webm files download?

One thing I discovered by accident, was that I could just leave the file names with the .mp3 extension, as long as the “Fileset ID”-opus16 is used and you make sure the source is good using the test button. I think the system matches the filename and must ignore the extension. You might try this with your audio files. If it still does not work I would click the “Contact Support” button in SAB and let FCBH know your difficulty.

image