App cannot be installed because it's integrity could not be verified

I just developed the ios version of the app. Tried to install for test with Xcode device as shown in the document, got the error “Unable to Install”.
Found the default icon on iphone, when clicked on it showed the error:
“App cannot be installed because it’s integrity could not be verified”
I have gone through the internet for knowing more about the error and found that there are many others apart from SAB having the same issue:
The app is working fine in simulator.
Is it really the issue or I have done something wrong?
Please guide.

Be good to confirm you are on SAB 10.2

Yes, I am on 10.2 Build release 108 (02- Dec 2022)

It might not be clear from the documentation. To run the app on the simulator, you don’t need a signing certificate. To run on an actual device, you will need:

  1. Apple Developer Program account
  2. Apple Distribution signing certificate
  3. App Identifier (the package name) registered in your Apple Developer account
  4. The device registered in your Apple Developer account
  5. AdHoc mobile provisioning profile created using the App Identifier and registered devices

Please see section 8 in Scripture App Builder: Installing and Building Apps on Mac on how to do these things.

Please see section 9 for setting up SAB to build the iOS App. You will:

  1. On the IPA Tab, set the type to Dedicated App
  2. On the Signing (iOS) Tab, select the Identity and browse to the downloaded provisioning profile.

After you have a built IPA, Please follow steps in section 11 for testing the app with Xcode.


Thanks Chris.
I tried all and the issue is intact. I have tested on simulator without signing certificate. Now trying to test it on actual device with adhoc profile, the app is not being installed. My macbook hasn’t itunes, neither it is showing. So unable to cancel allow this computer to access information. Should I install it from apple store?


You can ignore the part about iTunes. That is only relevant to older versions of macOS.


We’ve tried everything, but the issue is still intact.
We’ve paid apple developer account fees also just for this. Unfortunately we are facing the stated problem. Please guide.
Or should we upload it on apple store, build with app distribution profile, without testing on device?
Will it work?

Thanks Chris for giving me the time.
I am able to install the app on an actual device and it is working perfect, when I build it without deep linking. Though the deferred deep link is enabled. But no any deep link is being generated and shown when sharing verses to any social media platform.
With deep link enabled, it is showing the same error stated earlier in this post.

Please go through the issue and resolve.