App with audio crashes when built with 6.0.2

I am building on Windows and testing on my Android phone. The app works until I touch the audio/speaker button to turn on the audio, then it stops and closes itself. Any ideas on how to fix this?

Can you give a bit more info? Is this the only app you’ve tried? Did it work on a previous version of SAB? Is the audio included in the app, or is it trying to download it?
If you like you can file a help ticket here:

Where is your audio stored? I have a similar report where the audio is stored in the app.

Yes, the audio is stored in the app.

I just tried building another app that has audio that build successfully with 5.6 and it has the same problem.
Now I just uninstalled 6.0.2 and tried building with 6.0.1 and it worked.

Yes that bug is not in 6.0.1. As long as you don’t have FCBH analytics installed.


Given below is a feedback from an app builder on an app built using SAB 6.0.2 that crashes when trying to download audio automatically.

When downloading the audio file for a chapter from DBP, and NOT checking the box for “automatically download”, the app never crashes. Then, I uninstalled and then reinstalled the app. This time, I checked the box for automatic download. After that, the app crashes ONLY in the last chapter of every book.

This was reported separately a couple of weeks ago. While fixing the issue with FCBH Analytics, I also looked into this one. I have fixed this bug (auto download and crashing on last chapter of book) since 6.0.2. It will be in the next release. When I found it and I reviewed it with Richard, we realized it had been there for years.


Came across this thread after we encounter the same ‘audio closes the app’ problem. Just wondering if you have an idea of when the next release will be out - we’re wondering if we wait for the next release or go back to 5.6. You seem to release quite often so thought i’d check! We so appreciate all the hard work you guys do to make SAB possible! Thanks.

You don’t have to go back to 5.6, you can just go back to 6.0.1 and it works on that. I haven’t tried the new 6.1 yet but hopefully they’ve fixed it in that.

Version 6.1 is out and does not have this issue.