Attempting to play audio crashes app on latest build 8.6.5

I’ve been struggling over the last two months with this, and still can’t get it to work. You can see the app definitions here, and the .apk build can be downloaded here.

The app takes 52 minutes to build, and it does so without any errors. Then when I use it on my Pixel 3a it freezes when I try to use the audio. The audio is embedded locally. The launch time is great, and the navigation of the texts is fine. If I press play it freezes and eventually crashes, and zero audio plays. I’m using the latest version of SAB that was released in May.

That’s a very long build time… I see the .apk size is 792 MB, that’s very very large and I’m guessing that’s part of the problem even though it launches and navigates text fine. Why do you want the audio all included within the app?

I would recommend trying to set up the app in a different way - perhaps include within the app just a portion of the audio (maybe 1 book as an example to users?) and then have the audio available to download separately or set it up to download/stream from the internet.

All the audio included in the app is way more simple for everyone. SIL PNG did the same thing just fine here: Hebrew Resources – Pacific Institute of Languages, Arts and Translation
I’m using their same audio, but just adding more global languages. So there’s no reason it shouldn’t work because of the size.
Also, so far I haven’t seen SAB work perfectly and seamlessly in downloading or streaming audio from an online source. I’ve experimented with it for months and I find it too unstable.

Just trying understand a bit more - the example you cited from SIL PNG - does your phone have the same problems when you attempt to run their version?

Also, I notice that the SIL PNG example you pointed to do provide a version of the app that has audio externally provided as well (explicitly for users who can’t run the larger APK). I agree with you that all the audio included would be more simple…but it would be a good thing to test to help isolate what the issue is. If you can run your app fine when the audio is externally provided, perhaps there’s an unknown issue that’s occurring by having 38 collections AND that large of APK…just an idea.

I’ve been using SIL PNG’s version for years on different phones with zero issues.
I have tried sideloading the audio but it never recognizes the sideloaded audio. It simply never gives the option to play anything.

So should I just give up on this app entirely, or is there something I’ve configured incorrectly per the definitions file? Or is this simply a glitch that may be fixed in the next update?

@Andrew_Case lets get your current project and send it back to the developers. The last time was productive for everyone with multiple collections. So if the audio issues can be solved, it should help others too.

Now that SAB 9.0 came out, I’ve tried building the project once again. It gets hung up at 92% for about 20 minutes and then suddenly completes the build at about 45 minutes after starting. Then when I try installing the file on my Pixel 3a it won’t install. It simply says, App not installed. Before, with the exact same settings, built with the former vision of SAB, it would install. Here’s a screenshot of the build process at 92%.

Any ideas?

@Andrew_Case, since this a very large project, here are two things you can try:

  1. Increase the “Maximum Gradle Heap Size” in Settings > Build Settings.

  2. If your computer is slow or has limited RAM, try building the app on a more recent computer which has more processing power and more memory.

Thanks, Richard. I tried more than doubling the Gradle Heap Size to 3000MB. My computer is not particularly slow, and it’s running 8 GB of RAM. The app built within the same amount of time, but the size of the .apk bloated to 1.35 GB. Upon trying to install it, I got the same error. My phone has 8 GB of space left. Any ideas?