Audio sync with \v 1a, \s \v 1b

I’m investigating a bug with someone from Worldteam on the Oroko Scripture App. Acts 8:1 has a subtitle in the middle of it. It seems that Aeneas properly divides the audio, but phrase parsing fails to letter the segments consecutively. Thus the highlighting sync fails in the Builder and the App.

\v 1a Sɔɗi amokoa ɗo o maboɗoeɗi ime.
\s Sɔɗi Atatiɗɛ Ba-Baɗubɛ
\p \v 1b Nga bunya bone, botikiɗisɛ wa bokɔɗi wa ɗitengɛnɛ bato ba chɔchi waaboteɛ o Jerusalem. Bato ba chɔchi bɔ basusu baafangeɛ o bekondo ba Judea na Samaria, nga ba-ndomo* bɔ iti bamotɛ o Jerusalem.
\v 2 Bato bɔkɔ ba bamobokaka Obasɛ bɔngɔ, baafuɗa Tefani na ɗ’eja mɔ siɛ-siɛ.

The recording follows the order in the text. The produced timing file looks like this, and the numbering is off (1, s1, 1a, 1b…):

|4.720|7.804|1|
|7.804|10.388|s1|
|10.388|12.928|1a|
|12.928|19.608|1b|
|19.608|25.764|1c|
|25.764|29.120|1d|

When it plays, 1a plays and highlights, s1 plays and highlights, then 1a-1d highlights while the first segment after \s is played. After that, highlighting fails to continue for the chapter.

I attempted to corrected the timing file manually, and now the text of verse 1 fails to appear in “Fine Tune Timings” (presumably because 1e does not exist as a phrase). I can’t seem to find/edit the underlying phrase file under the hood to make sure that the numbering is consistent (editing phrases wants to create a copy in another folder and I can’t find the local ones):

|4.720|7.804|1a|
|7.804|10.388|s1|
|10.388|12.928|1b|
|12.928|19.608|1c|
|19.608|25.764|1d|
|25.764|29.120|1e|

It seems like the logic of a split verse with an intervening \s doesn’t process this order consecutively/correctly. Any ideas?

This topic is discussed here:
How to handle timing files for verses numbers already split - Scripture App Builder - SIL Scripture Software Community
I think you have the right idea adding the ‘a’ on the ‘1’ (and of course changing a to b, b to c and so on), but you need to make the same change in the Phrases file. The Phrase and Timing files work together. You should be able to find a folder called Phrases in your Scripture Apps folder (if not, just search for it) and find the file for Acts 8 in there.

We have this as a bug #681. I’ll add the extra info here.

It looks like I can’t work around this bug by fixing the timing and phrases file.

After reading and talking with Jeff, I was making progress, tweaking the timing file to use the 1b=a syntax helps somewhat. I still can’t get it to pick up 1a from the phrases file, only 1, which is not correct. ​
So, SAB uses the timing file and a phrases file to run the playback, editing the timings file makes an immediate difference in SAB.
I can “export” and edit a new .phrases file, and it ends up in a folder external to the project. Editing this new file seems to have no effect on the app. It’s as if there is a hidden “phrases” file in SAB that I can’t correct, or it creates it, wrongly in this case, on the fly.

The external placement of the phrases folder seems like a secondary bug, why would it not be in the folder with the rest of the files? Where are the phrases “guts” that SAB is actually using?

I have no insights into the ‘guts’ of SAB but if I remember correctly I ‘re-fine-tuned’ the chapter after changing the phrases file. I didn’t actually change anything, just pressed save. I think this helped SAB recognise the changes made in Text Editor.

When you use the “Export to HTML” option and it opens in a browser, if you right click to see the page source and see the raw html, if you scroll down you can get an idea of how the “guts” are formatted courtesy of the “div id”. Unfortunately I’m not sure how helpful that is because I couldn’t find a way to manually edit the underlying hml that that would work. But at least you can see the “guts”. Or maybe you will be able to get it to work.