Bookmarks, Notes, Highlight pages empty

I made a new app, but for some reason, when I make bookmarks, notes, and highlights, none of them show up on their respective pages. Did I do something wrong or not turn on a setting?

@ChristopherF, did you make sure in the Annotations tab under Features, to check the boxes for Highlighting, Notes, and Bookmarks?


I noticed the same thing today. Tested it in two different apps. Annotation screens not working in SAB 9.1.1 Can this be fixed please?

Addition: apparently this wasn’t working in SAB 9.0 either. Strange that people are not noticing it… I tested it on Android 5, 7 and 9. Emulator and phone.

Sorry to hear about this problem. It is working fine for me with the latest version of SAB, so there must be specific circumstances that cause it to happen. Any more information that you can provide to help us track down the problem will be much appreciated.

Hi @richard, I can’t figure out what causes it. I tried it in several apps, with APKs and as a download from Google Play (AAB). I built a simple test app with just a couple of books, other apps have more than one book collection. I tried turning off some options. I have installed SAB 9.2 now. I just don’t get it to work. I know two other people whose apps show the same behaviour.

@Friedo if it is always happening with certain app projects on all phones, then please send the project to me so I can see if I can reproduce it. Thanks.

I shared the files with you, thanks @richard. Some additional information: I was checking an app where this was happening. After doing lots of different things in the app, it suddenly started working. Then I uninstalled and reinstalled the app and tried to reproduce it, but first couldn’t. Then I triggered a verse-of-the-day notification. And sure enough, after I received it, it started working! I repeated this twice, just to be sure and can confirm that after receiving a notification, it works in this app, funny as it is :slight_smile: Not sure if this information is helpful…

Thanks, I got the files and I was able to reproduce the problem. I will investigate further and try and provide a fix for this.

1 Like

@Friedo, @ChristopherF, please can you try Scripture App Builder 9.2.1 to see if it fixes this problem. Thanks.