Bridge passages

SAB is not including bridge passages with \iex USFM. Also how can I ensure these passages are italicised in the app?

@Alex SAB should be recognising \iex paragraphs as bridging text between passages of Scripture text. The default style is set to italics. I have just tried it out with the most recent version of SAB and it looks to be working.

If it is not working for you, please can you send a sample to the Support team and we will investigate.

Thanks, Richard, I’ll do that. I’ll send a usx file that includes \iex paragraphs that are not appearing in the app though they show up beautifully in the SAB viewer.

I have discovered that the \iex paragraphs appear at the end of the book in the app instead of the correct location. The \iex replaces the correct final chapter.
If the \iex occurs at the beginning of a chapter, it seems to behave OK.

The USX I saw was not valid XML The para immediately before the \iex was not closed.

My usx file is exported from Paratext. So does this mean there’s a problem in Paratext? I don’t see any way to close paragraphs manually.

If it is exported from Paratext then it should be valid. Since it is not valid then I’d report it to Paratext.

Please specify the ways in which the file is “invalid”.

I have found a work around replacing \iex by \lit which we’re not using otherwise and editing the style. However, since the files work perfectly well with other paragraph styles, it seems there is a problem with SAB’s handling of \iex.

A USX file is an XML file. Each element must be closed. In @Alex case:

  <para style="p">
  <para style="iex">Wete ... paipaidi.</para>

In USX schema, a paragraph can never contain another paragraph. So the first <para style="p"> above is not closed, the closing element can’t occur after the start of the next paragraph. The first line should be either: <para style="p"/> or <para style="p"></para> to be valid XML. Both of those two options are invalid USX but valid XML. An empty paragraph should be a b like <para style="b"/>

Wete Iave Mosese ivoneni tomo’otoqa kanasala inakalaqei kaisayanidiavo mesaida sipi, gouti, malasi wete bunetutu mwanewaudi inagabunidi velomu paipaina wete vemataluananidiavo ivoneni kaisayanidiavo paipaidi. looks to me to follow the example from USX
So how should it be closed?

The problem is not the iex paragraph,. It is the one before that.
It should be:

  <para style="p"></para>
  <para style="iex">Wete ... paipaidi.</para>

Sometimes an error like the preceding paragraph not being closed can cause issues with what follows. In strict XML processing an error with a missing closing element would result in no output at all.