Bug - SAB 4.6.1 rushes through whole book if audio not found

Hi all
I’ve been working on a new SAB audio app, with audio files in external storage. I’ve found that if the user hits play and the app fails to find the audio, with default settings (i.e. auto advance to next chapter) the app continues to advance rapidly through all the chapters of the book, and cannot be stopped if the user hits ‘pause’.

Are you saying that the app is not downloading the files from the Internet they are just present on the SD card. Are you saying the file is there but the app does not find it or when the file is not there the app skips on. How do you know the device can’t find the file?

Have you tried moving the files to internal storage?

With files downloaded from the Internet apps on some devices are exhibiting this behavior but it is not happening on all devices. This sounds similar but the context seems a little different.

How many devices is this happening on?

The app is currently not setup to download from internet, just to use audio downloaded separately. The file is present on the tablet in MainStorage (actually internal, not external), in the folder which corresponds to the source I have set up in SAB. The first time I hit ‘play’ I briefly get a message ‘Audio Not Found’, but then the app skips automatically through, for example, all 50 chapters of Genesis as described in my first post.
This is on a Lenovo TB-X103F (Android 6.0.1 - security patch level 1 June 2017).
It DID find the audio on the tablet the first time I built it, now it doesn’t with no deliberate change in the SAB settings.

I just transferred the app onto my MotoE 2nd Gen (Android 6 - security patch level 1 Dec 2016), and at first it worked fine, but now when I hit the speaker icon on a chapter for which I HAVE the audio, it always advances to the next chapter (for which I DON’T have it) and says ‘Audio not found’ (but it doesn’t advance further).

Could this strange, inconsistent behaviour be due to the android security being gradually tightened?

I transfered all the audio over to my MotoE phone via ShareIT, and now I now have the same behaviour on my MotoE - it doesn’t find audio, but skips through all the chapters.