Build fail error


This is the error report I have been seeing when I tried to build my app. Please help Sirs

Let’s start by looking at your Android SDK settings. In SAB, go to the tools menu and select settings. Then click on the Android SDK tab. Take a screenshot and post back to this thread. This is how mine looks…

image

Thanks so much my dear brother. Below are the screenshots sir but I believe that the problem might still be from the SDK installation. I have this suspicion from the second screenshot.


as you can see, all are installed but when I clicked on ‘install packages’ again, below is what I found
Thanks for your anticipated assistance Sir

I’m on the newer side of this team and still learning. Looking back at your original post, it shows that there are licenses that have not been accepted. Googling that it appears that others have had to deal with that on multiple platforms. I googled (without quotes), “license for package Android SDK platform-tools not accepted” and got a number of hits. There are some youtube videos that might help. They seem to mention a tool that can be run to accept all licenses.

Thanks so much sir.

I’ll appreciate Sir if you can send me a YouTube link that can lead to such videos.
God bless you

This may be getting outside of my capability. I did look at the youtube videos and they seem to be in the context of Android Studio which you’re probably not using. I don’t know your exact setup now am I familiar with the particular problem. I’m just trying to help point you to possible solutions. I would again suggest you do the same google search I suggested and see if you can find information that fits your configuration. I’ve seen a few different references to an SDK tool by the name of sdkmanager that may be able to do the job to accept the licenses. I’m being cautious because I don’t want to give you the wrong information and possibly make your situation worse. If you can’t find a solution, then I’d make another post that focuses on the message, “license for package Android SDK platform-tools not accepted” to see if someone else has solved that problem.

1 Like

Thanks so much sir. I’ll do everything you said when I get to the office tomorrow. I sincerely appreciate your concerns and responses. Truly I don’t have android studio. Maybe I should try and install it I think?
I so much appreciate sir

One link you may want to look at is:

He mentions the command: sdkmanager -licenses

I’ve also seen it mentioned elsewhere: sdkmanager --licenses

1 Like

Wow! Thanks so much sir. I’ll vividly study the article tomorrow. I appreciate your efforts Sir.

I am really tired, frustrated and perplexed. I tried all the methods, some can’t be done. For example, that directory called ANDROID_HOME is not even available in the environmental variable on my system.
I pray I get this fixed

Before going that route, go back to the documentation and carefully follow the steps to install.
There may have been something you missed.
Also, check where you installed the Android SDK and see if the Android SDK Location path is the same. Your screenshot does not match what is in the instructions.

Ok Sir, I appreciate. I will check the documentation you showed above and I will uninstall the app to reinstall it again. I really appreciate you sir.
Sir, if I can install android studio on my system, can the problem be solved?
I am considering installing android studio and full JDK version 8 except if you advise me against it @GregAshleyCooper and @LloydG

@GregAshleyCooper and @LloydG I think I mentioned it that the problem was a software error. That time I was trying it was the time they were changing from cmdline 4 to 5. The same thing I did that didn’t work, I tried it again today and it worked