Command line tool

I am having problem building my app using the latest release of SAB app. The problem I have is command line tool installation. The SDK I used for the former SAB release doesn’t work with the new release.

Is anybody having same problem?
Assuming I install android studio, will the problem be solved?

Kindly help please
Steve Jacob

Did you try following the installation instructions? You do not need Android Studio.


1 Like

I followed the instructions manual Sir. I think there’s a problem with the command tools I’m downloading from the software. I followed the instructions critically Sir. When I used version 8.6 of SAB I never had this experience.

When updating SAB v9.0.1 it was not a problem for me. I was able to update the SDK at that time.

1 Like

Sir @ChrisHubbard and @MikeB, that was when the associated SDK tools was command line version 4. Now, it’s version 5. If you uninstall your SAB now, download a fresh .exe file from the internet, you will face same problem I’m facing. When I got so depressed and frustrated yesterday, I decided to install a copy of one of the past SAB I have on my system and there was no issue. I used it to do everything I want to do but I’m not going to publish it since Google wants every app to be compatible with Android 11 or so. I’ll still wait till I resolve my issues with version 9.0.1. I pray I get it solved on time because lots of people are waiting to see the update I’m working on.
I don’t mind downloading and installing android studio fully if it’s going to help. Please I need your advice on this. Thanks so much in advance.
If installing android studio will solve the problem, I won’t waste a minute before I do that but I want to be sure before I do such.

Steve, if your Android SDK installation is not working for you, it is probably best to delete its folder completely from your computer and start the installation again.

Select Tools > Install Android SDK and follow the instructions in the wizard to download and install all the Android SDK components.

You do not need to install Android Studio.

@GregAshleyCooper and @LloydG I think I mentioned it that the problem was a software error. That time I was trying it was the time they were changing from cmdline 4 to 5. The same thing I did that didn’t work, I tried it again today and it worked @richard @ChrisHubbard @MikeB