End of Ayah issues?

I have tried to use it with many different supported fonts but they do not work. however, when exported to html they seem to display properly. I am using wasta linux.

Does anyone have any suggestions? I have been trying for many months and retrying with every new release.


Hi Jonny, please could you be more specific about what the problem is?
Could you include another screenshot so we can compare the good with the bad?
Many of us, including myself, have experience with Arabic-style scripts in SAB. I am confident we can help you.

Hi Craig,

the problem is: the numbers should be inside the circle things,

here is an example

Here you can see the numbers are inside the circles. This page was also generated by sab but it works properly.

Thanks a lot!

The image is a result of the html export feature

I guess I started off over-confidently :slight_smile: . I have never tried that and don’t even know how to do it, I’m sure someone else here has though.
I found the end of ayah in Styles and played with it a little bit. I couldn’t get it to make a circle. It looks like you are ahead of me on this one. Good luck.

Can you send me two verses in SFM for me to look at and experiment with?

\c 1
\v 1 اوَلدە سوز واردي۔ و سوز اللهن يانندەدي و سوز اللەدي۔
\v 2 او اوَلدە اللهن يانندەدي۔
\v 3 هر شي اوندن يراتلدي و يراتلمش شيلردن هيچ بيري اونسز يراتلمادي۔

The idea is that you type ۝ followed by a number. When it is in a supported font the numbers enter into the box.

۝٢٢ does not appear because the font that the messageboard is in, does not support it. The SIL fonts support this feature so it works, but in the SAB it works on the html export but not on the android app

Scripture App Builder 8.6

Release date: 15 March 2021

End of Ayah verse number formatting

Verse numbers can be displayed inside a decorative End of Ayah symbol.
See Styles page for the book collection.
This feature will work only if the font supports End of Ayah, such as Scheherazade.

But does not display correctly.

I did testing with your sample SFM data.

  1. In HTML it works as you explained.
  2. In the SAB Viewer it does not work. This viewer is for quick reference, it has issues. This is another issue.
  3. NOX Android emulator it does not work either.
  4. On a phone Android 9.1 it displays correctly.

As 1 and 4 work I don’t think we should worry about 2 and 3.

Are there particular Android versions that it is not working for?

Thank you for looking into this!

I have tried it on my local devices, phone, tablet, ebook reader (boox android) none of them are that up to date. The newer android must work then, but the target audience here in the middle east are using used phones that do not have android. The emulator that I used was anbox.

my phone also has android 7.0

It seems that end-of-ayah only works for Arabic-script digits in the U+0660-0669 range (what SAB refers to as “Eastern Arabic”). The Scheherazade font supports end-of-ayah for that digit set as well as the Persian digit range (U+06F0-06F9) and the Latin (Western) digits (U+0030-0039). Even if support is restricted to Arabic script digits, it should at least work with the Persian digit range as well as Arabic proper. But our project would also like to have it work with Latin digits, as in your screenshot.

Is there any chance of getting end-of-ayah to work with Persian and Latin digits? Persian works with Scheherazade in other programs (eg, Wordpad), but Latin doesn’t always work, although it does in Notepad. I suspect there could be an issue of Latin digits breaking the text run in the rendering engine being used in SAB, but it would be good to investigate the feasability of getting it to work.

Hi Thanks for the note!

I have tried using both latin and arabic script with the same results.

I wonder if it only works with version 8 and higher.

My phone has Android 5.1 and it works there for standard Arabic digits.

I was using font Scheherazade-Regular.ttf

I downloaded a new version of the font and now it is working! I am a bit surprised as it was working on the html output but not in the apk. Now it seems to be good to go. ScheherazadeNew-Regular.ttf works fine

Sorry for bugging everyone. Very glad to see this feature finally work!

Don’t worry about bugging people. We all learn more by reading about issues.

A BIG thank you to you for reporting that it is working properly now. A long dialog without a resolution is what we don’t want. (I need to update my font too.)

Thanks for reporting back.

1 Like

the embedded Scheherazade did not work i had to download a newer version and it worked.

1 Like