First line of song not displayed with \q2 style

Great to see so many of the SAB support team at the advanced training this week! Thanks for your hard work. I’ve built a Song book app for the first time - and its looking good. The only problem is where a song starts with a chorus/refrain. In these cases, the SFM for the song starts like this:
\c 96
\s Jimol Ɓangal
\q2 Foofoo maa Laamɗo, foofoo maa Laamɗo

In the app-level styles page, I have modified div.q2, div.q2-v, div.q2-vv all have an italic font-style.
This works for all other places in the song, but where the first line is \q2 it isn’t italicised.
Is there another style I need to modify? I can’t see it easily.

Just noticed another thing - trying to replicate the song book, I put in author information under the title, right-aligned, bold in a small font, using the \lit marker (which I’ve modified on the styles page)

\c 96
\s Jimol Ɓangal
\lit P.B.S. 27-12-2001
\q2 Foofoo maa Laamɗo

In this case, the chapter number appears on the same line as the author information in the \lit marker, in the same small font.

For songs I don’t show chapter numbers.

Features > Formatting > Show Chapter Numbers should be unchecked

Or check Show Chapter Numbers but change the Position of number to At the top of the page

I tested and have my first \q2 line italicized. My chapter settings were for no chapter number or chapter number at the top.

I get the first line italicized. so I can’t reproduce your error.

I’d need to check your project.

Hi - just to say, I had a work-around when I put chapter number at the top of the page. I think there is an issue with the styles code when the chapter number position is ‘drop cap before the first verse’.