Footer different in app and html

I am having some minor difficulties with the footer in my app. It appears differently in the SAB Viewer, View in Browser and in app (either simulator or on actual phone).
As is often the case, dealing with RTL and html can cause problems, this happens with WordPress as well.
First is a roaming bracket, I have the word Biblica in brackets (ببلیکا) at the end of the sentence.
The end bracket will stay in place sometimes but go back to the start of the sentence in others.
The other is the copyright symbol which appears at the start of the line, but when zoomed in enough for that line to be divided onto 2 lines, it moves to the start of the second line which looks odd, especially when that puts it in the middle of a list of years.

This is how it appears in the footer editor in SAB:

This is in the SAB Viewer, with the bracket out of place:

This is in the browser, and how I want it to look:
Screenshot 2021-03-16 at 12.21.12

This is the bottom line on one line in the app, which appears the same as the viewer:

But when zooming in the © moves to the start of the second line:

or even on its own:

My questions are:
How can I keep the © at the start of the line?
Can I improve the html in a way that makes the bracket appear at the end on all platforms?

RTL is not my strong area. I am hopping some one else has a good suggestion.

The Copyright at the end of the line seems wrong. Should it not be at the beginning of the line in the footer editor.

Is your footer text direction set to RTL.

When I test with some borrowed Arabic the Copyright that is at the beginning of the line in the SAB footer editor, the © then appears at the very right in both the viewer and the Browser. That should fix the wrapped line issues.

The built in viewer uses JavaFX. JavaFX has some issues. It does not support italic.

1 Like

I would agree with Ian that the © symbol is probably actually at the end of the line in your footnote. A helpful trick when working with RTL text is to tap the Home key to go to the beginning of the line, then hold down shift while you press the right arrow key (note that depending on the program you are in, you might actually have to press the left arrow key instead…). This will progressively select the different letters in the line. The selection of letters may not work quite right (again, depending on your program), but will probably give you some idea which letters come where.

I would recommend that you copy the copyright line and paste it into LibreOffice Writer or MS Word to do your editing there, as those programs understand RTL a bit better, especially around highlighting and things like that. Then you can make sure that the © symbol is actually at the beginning of the line.

But I’m also thinking that SAB is in reality treating that footnote text as LTR. So as Ian suggested, make sure the footer text direction is RTL. (That is in the Footer tab of the Collection.)

As for the parentheses, they are “weak” in directionality and try to take the direction of the surrounding text. So sometimes you get these funny splits. It may be that setting the Footer text direction is sufficient to sort that out. If not, you may need to insert one or more RTL marks in the string to force the direction. This is character U+200F. In Word you can get that by typing “200F” and typing Alt+x. Try to insert one of these characters right before the closing parenthesis, to see if that puts that character at the end of the line where it is supposed to be.

1 Like

Thank you both for your replies.
It was indeed not set to RTL for some reason, I know I had done it in the past but for some reason it was back to LTR. Probably human error (and I’m the only human who has touched this project. :sweat_smile:)
It is now behaving correctly.
Copying it to Word or something else that copes with RTL better is a good suggestion, without doing that, I have found it especially difficult to insert a space where you want it.
It did prompt me to double check with the Bible publishers where they want the © to be. Where they publish they are not bound by any international copyright conventions so there is no local standard. In the printed Bible it is in an English copyright line but not in their corresponding line just beneath.
We might actually put it in the middle between the words for ‘all rights reserved’ and the years.
Thanks again.

I have found that the Text Direction setting for the footer keeps resetting itself to LTR. I’m quite certain I didn’t change it back myself because it happened with all 3 languages in all of my projects so I don’t think it could have just been an accidental click.
It was back on LTR on both the the Books>(relevant collection)>Footer>Text Direction and in Books>(relevant collection)>Styles>Footers>div.footer>direction.
Is this a bug?
I’m also wondering why these are not linked, why one does not change the other and which one takes precedent.