Footer incorrectly displayed in verse-by-verse

As you can see in the image, the footer doesn’t have a background. Also, the text is supposed to be centered but it doesn’t work. This occurs in verse-by-verse mode when the second text (blue font color) has a footer.

Hi Friedo.
I would try Styles>Text Styles>Footers>Footer Box as pictured below:

And change the background colour to perhaps FootnoteBackgroundColour or Pane2BackgroundColour.
Also try to centre the text here under ‘text-align’.
You could further distinguish the footer from the scripture text by making it smaller under Books>BookCollection>Footer>Text Size where it is a % of the scripture text, I have mine at 70%.
Hope that helps,

Thanks for your response Craig. Maybe I didn’t explain it well enough. These settings are all in place and the footer is displayed correctly in most layouts. This problem just occurs when the text is displayed in verse-by-verse and the text to which the footer belongs is second. So it definitely looks like a bug.

Ok, since I have a footer for all of my languages I can’t replicate that problem. On mine they both (or all 3) align centre.
In 2-pane mode, if the language with the footer is in the top pane, does the footer have a background? In my app the top pane doesn’t but the bottom pane does. I always thought that was odd but haven’t bothered changing it.

Have you checked the Books>(book collection)>Styles>Footers>Footer Box as well as the main Styles section?

Have you also tried the text-align in ‘Footer Box Pane 2’?

Thanks, it’s interesting that they all align well in your case! No, for me it doesn’t work, I tried your recommendations in Styles but it doesn’t help.

1 Like