\fr references in footnotes use . instead of :

I am using PTXprint 1.9. The USFM file I am working with has footnotes but doesn’t include the \fr marker. It seems that PTXprint is including them for me. (Much appreciated and that is something we should probably fix.) But the format of the reference is ch.vs regardless of the choice of . or : beside Verse numbers in Header References on the Header + Footer tab.

It there a way to have PTXprint check the choice of . or : in references as set on the Header + Footer tab when it adds the \fr to the footnotes where it is missing?

In a related question, I can’t find a setting to remove the \fr references from the footnote in the notes area. Have I missed that setting somewhere?

Update: I’ve been working with the USFM for a very long time and have never used \fr. Didn’t realize we needed it. But someone outside our team needed access to the files in Paratext and added the \fr markers for us. And they used . instead of : which added to my confusion. My bad for not noticing this before I posted!

But I guess my questions still remain. Would it be possible to add a setting to include/exclude \fr and to use whatever chapter/verse separate is set for references in the headings?

I’m assuming your current footnotes look something like this:

I’m a little bit confused as to what you’re asking for, but I think you want a way to not display the ch:vs references in the footnote area so that it will appear like this:


If so, here’s an easy way to do that:

  1. On the Notes and Refs tab, set your settings as shown:

  2. Then click \f to take you to the style properties, and select the fr - fr - Footnote - Reference style on the left:

  3. Finally, check the box at the top of the right pane to Hide/Exclude Contents of Marker, and hit Print.


Great! Thank you! I hadn’t noticed the Hide/Exclude Contents of Mark in the Styles tab. That is exactly what I was looking for in trying to remove the reference from the footnotes. I’m still learning and there are a lot of settings to work through.

The second part of my question was how to replace ‘.’ with a ‘:’ in the \fr in the footnotes area of the PDF. We have decided to hide \fr in our PDF but what if we wanted to change the ‘.’ to ‘:’ to be consistent with the reference in the page headers? We chose the ‘ch:vs’ option instead of the ‘ch.vs’ option on the Header + Footer tab. To answer my own question, we can a) change the ‘.’ to ‘:’ in our Paratext files, or b) add a regex to PrintDraftChanges.txt. Just wanted to add these thoughts to close up this topic.

You can use a regular expression in the find (or in RegEx Pal) to make the change from . to :
In the find you must start with regex:

Here is one possible search:

regex:(?<=\\fr \d+)\.(?=\d)

This says, do a regular expression search for a period preceded by \fr and one or more digits, and followed by a digit.
The replace string would be just the colon.

If you wanted to find any period preceded by a digits and followed by a digit you could remove the \\fr

1 Like