Handling of short verse 1

I have been hitting a problem with the formatting of verse 1, especially in 1Co 11. There may be one or two other spots that have the problem. The section heading above verse two is pushed over because there aren’t two lines to go beside the drop cap chapter number, and the chapter starting with verse 2 is over indented. My current work around is to add a \p or \m and some junk text, so that it fills in properly, then open the PDF page with LibreOffice Draw and delete the junk text. It would be nice if it would flow in well without this hack.
I would share a link to a drive folder with examples, but the forum software says I can’t as being too new a user. If anyone is interested in that data, you can e-mail me.
–Loren

Thanks for raising this as an issue that you would like to see improved in future. You can send the link of the drive folder to ptxprint_support@sil.org and we’ll take a look.

Hopefully you’ll also soon be able to post images and files on this forum too [I’m not sure how that is controlled, but it obviously works for some people :slight_smile: ]

Thanks. I emailed the link.

Out of interest, I checked how we handled this in our own project, and found that the \nb (no-break paragraph) solved the issue for us.

image

which then produces this with PTXprint, but also with other typesetting software:

image

Would that work in your situation, or do you need the v1 text to be in its own individual paragraph?

1 Like

That looks like a great solution. Beats having to extract the one page, doctor it in Draw, and replace the original page, as I had been doing. Thanks. --Loren

I just updated to the latest 2.2.40. I am hitting the 1Co 11 verso 1 problem again. In this version, there is a section heading at verse 2. It starts on a new line, but the section heading and also the start of the text has an extra large indent. My current work around is to add a \q4 to verse 1 with just a period as the text. I edited the \q4 style to make the text white. We pretty much never have a real q4. I was reluctant to use the nb solution, since it will change the flow of the text from what is marked up. This is a decent work around, but it would be nice to have a fix some day.

If the translators have put a section break at verse 2, do they really want verse one starting its own paragraph? I’d be quite surprised if that was the case, unless every verse is it’s own paragraph.

The large gap seems surprising. Does verse 1 fit on a single line? In that case the cutout would continue.
You can include \cancelcutouts before the paragraph start in order to forget about all cutouts. You might like to use \b (empty line) for spacing purposes, that sounds simpler than your \q4 work-around.

Thanks, David. The Spanish version that our translators usually follow does the sectioning this way. Verse 1 does fit on a single line. I tried the \b, but the section head and verse 2 paragraph still had extra indent. The \q4 work around is cludgy, but it seems to come closest to what I need for now. Maybe the \cancelcutouts would do the job. I wasn’t aware of that option. I appreciate your help.