How can I get small caps on \nd

I want the \nd style to be in small caps. When I export from PT to RTF, \nd is underlined. I checked the box for small caps in the \nd style definition in PTX Print, but when I print to create the PDF, there’s no distinction of style whatsoever. What can I do to get small caps?

The key to getting smallcaps to work is that you need to use a font that has true smallcaps (i.e. is an OpenType or TrueType font that has the smcp feature). Charis SIL, etc. do support small caps. Many fonts don’t.
image

My font is Tahoma for which we purchased a publishing license to use in the printed NT in 2012. The typesetter got the small caps to work easily then. MS Word also handles small caps with this font without a problem. I have a version of Tahoma TTF from 2009 which I think I downloaded for the typesetter, but is it advisable to install that (retrograding) over the 2018 version currently on my PC?

As an experiment, I switched to NotoSans which is available for Scripture App Builder and displays Small Caps nicely in the Android app. But PTX Print still fails to make small caps display.
In fact, I can’t get small caps to display with PTX Print, even if I switch to Charis SIL…

I just tested a number of fonts in PTX Print and in LibreOffice Writer. Writer displays small caps in every font I tested. Wikipedia says most word processors ignore “true small caps” glyphs by default, instead they fake them by scaling down normal capital glyphs under the hood. I’m guessing PTXprint does not include this “fake” technique for small caps.

In my PTXPrint Andika New Basic and Gentium Basic do not produce small caps, but Andika and Gentium Plus do. Charis SIL and Charis SIL Compact also both “work” for small caps.

If small caps in Charis does not “work” for you in PTXPrint, I wonder if you might need to update either your PTX Print version or your Charis SIL font version, or maybe both? It’s easy to forget that most SIL software items are regularly updated and improved.

I strongly suspect that Tahoma does not include small caps. Check out Microsoft’s specs for Tahoma, compared with Calibri at docs.microsoft .com/en-us/typography/font-list

Interesting discussion on Wikipedia, if you are interested: Search for “small caps” there.

Finally, if you want a Sans font that looks good you might try Andika. Andika was developed as a literacy font so it defaults to “primer a and g.” But you can change these glyphs in Paratext, PTXPrint, InDesign & LibreOffice to the “normal” non-literacy variants. In the PTXPrint Fonts+Script tab click on the Body Text font. Choose Andika. Then tick Graphite Rendering and click the Select Features button at the bottom of the dialog. For Andika and its variations the feature, “Literacy Alternates” is ON by default. Untick it and click OK in the Select Features dialog. You should now see “litr-0” next to the Select Features button. We use Eng and Glottal variants as well, as you can see in the screenshot.

image

First of all, I want to say that this is my first time using PTXPrint and I am really impressed! Very user friendly. Thank you development team!

I am having the same problem.

I just checked, and I have the most recent version of both.

I also found that the marker \sc \sc* also comes out without special formatting. Here is my source text and the PTXPrint Export:

\q1 \v 2 Jacob runacunapa achca marcan caycaptinsi, Sión marcatam \sc Taytanchiga\sc* sumaj cuyan.
...
\q1 \v 6 Acta librunman runacunapa jutinta isquirbir, \nd Tayta Diosninchi\nd* ninga:

image

Here are my settings:
image
image
image

Any ideas on how to get small caps?

Thanks so much for your help!

Alex

1 Like

I was able to get success with small caps after updating to the latest version of PTX print and by redefining the \nd style. My preferred font is Tahoma. But I could only get the small caps with Noto Sans. These fonts are similar, so I find it a reasonable compromise to use Tahoma for the entirety of the publication and NotoSans only for the Name_of_Deity style.