Install APK Error Type 3


I received an error when trying to install the APK file. The app built successfully, but it will not install. Any ideas? Photo attached.

This happened after I updated the audio files in the app.

Sarah Jane

To start at the basics, is your phone turned into a developer phone? Press on the Build number 7 times? Has the developer menu item shown up? Is USB debugging turned on?

As much as possible I use my phone to build then load my apps on my phone. But I get inconsistent results. One time it works and the next it fails. So I have an emulator (Nox player) running on my computer then drag a copy of the APK to that and test there.

A quality newish USB cable is a must. You computer and phone should recognize it when it is plugged in.

The older the phone age, means the contacts are more worn. Connections can become less reliable.

At times restarting your phone may help.


It was a yes to all the “basics” questions. The next day, I just tried the same thing and it all worked perfectly. So, as you mentioned, I guess the results are just inconsistent.

I’m trying to get things set up with an emulator as well so I can have more consistent results.

Thanks again for your help.

Take care,
Sarah Jane

1 Like