Installation with arm-based processor

Hello,

At installation I’m getting the error “This program can only be installed on versions of Windows designed for the following processor architectures: x64”

I’m running windows 11 through Parallels on a new mac. It turns out the processor type is “arm-based”. Is this an issue that’s easily resolvable? I realize this probably doesn’t affect many other users, but other SIL software has worked fine for me so far.

Any help would be appreciated, thanks!

From what I can read, Parallels only supports ARM virtual machines.

One option is to use QEMU virtualization that can support x84-64 OSs.
I can’t test as my Mac is Intel.

I also don’t have an ARM machine and so can’t test, but my understanding was that Windows 11 (but not earlier versions) would emulate x86 and x64 architecture in ARM.

This page indicates that that is true, though it does say that x64 is only available on builds later than 21277. It also seems to say that no extra setup is necessary–it should just work.

Ok, I’ve tried a few things like activating/updating Windows 11 to the latest build (22000), but still no change. I’m a little intimidated by what I can see of QEMU – I think out-of-the-box software like Parallels is more my level for the most part.

If you have time and want my feedback to troubleshoot I’m happy to collaborate, otherwise I’ll probably just sit on it for now.

If the desire is to get ptxprint working (rather than parallels) then the step-by-step components would be:

  1. A XeTeX installation
  2. Python-3 with relevant libraries, including gtk (3 I think)
  3. A pdf viewer

Sorrry, I forgot to say (if it’s not clear from my reply)… ptxprint is cross platform.

As a test, I’ve just been playing on a headless ARM-based NAS box (odroid HC1), running devuan linux, and it looks like it should be fully functional with a bit more love and care (not having all the right fonts or paratext installed on the machine makes things bit harder!)

Hi David,

Sorry, you’d need to spell it out for me a little more. I would install Livetex or something and Python 3 on my Windows 11 virtual PC and then it would just work or what?

I’m thinking it’s probably easiest just to borrow another work computer to print scripture. Thanks for checking into it!

Sorry for being too brief (and it seems that emailing a reply doesn’t work).
I was suggesting that you might be able to run ptxprint natively and ignore the whole parallels mess.
I really don’t know, I’ve not used any apple product since about 1998.

If google tells you than someone has worked out how to run glade / gtk-based applications written in python3 on your machine, and you can find a XeTeX distribution for your device, then there’s no need to go to parallels. It’s all cross-platform, open-source software, after all. I think it really depends on how hard Apple have made it to run GTK-based apps natively.

Failing that, maybe there’s a way you can run a linux virtual machine? PTXprint certainly runs on linux.