Link glossary word from footnote

I’ve searched the archive, but couldn’t find an answer to my question.

The project has a GLO file with all the glossary terms. There is a \c 1 at the beginning of the file, and each glossary word is marked with a \v.

The project has the glossary words (\w …\w*) in the footnotes. When I click the link in the app, the footnote appears, but the glossary word appears as normal text, with nothing to indicate the word is a glossary word. Also, there isn’t a link to glossary term in the footnote text.

Is it possible to link/jump to a glossary term from within a footnote?

Can you show a few words of your GLO file? You have not mentioned any \k word\k* markup.

\c 1

\v 10 \k fortress\k*: a huge and secure stone building or group of buildings in which soldiers take cover to defend themselves from attack. The Antonia Fortress was next to the Temple complex in Jerusalem, as shown in the picture below. When the Roman army occupied Jerusalem, they stationed soldiers in this fortress to maintain order and control. The Apostle Paul was held in this fortress for a day. \fig |Wikimedia Antonia Fortress.jpg|col||Wikimedia Commons|Antonia Fortress in the first century|Acts 22:24\fig*
\v 11 \k Galilee\k*: a region south of Lebanon and west of the Jordan River. This included the Sea of Galilee, which was also called Lake Gennesaret and Lake Tiberias. \fig |Jalil_Galilee.jpg|col|| (labels added)|Galilee and surrounding regions|Luke 2:39\fig*

If the Keyword is not bold then look at your styling for span.k in the Special Text section. It is by default set to Bold. The rest of the text should not be bold.

The glossary items do not have a link to the glossary, since there is no contextual information, unlike Scripture that has lots of context.

If you want to have a link then use a Markdown linking structure to the GLO. It needs to be like you have it with Chapter and verse. Then you can put in [absolute](GLO.1.1] in your text if absolute is the first word in your Glossary. That provides a reference like link that lets you jump to the Glossary like in a cross reference. You can use Changes to automate that for you Glossary words. Setting up the changes would take a while unless you can automate the process.
I’d also divide the glossary into chapters where the word starting with A are in chapter 1 etc.

\c 1
\cp A

That way the Glossary chapter numbers are replaced with letters.

Thanks for the information. I’ve been able to make some progress with identifying the glossary words, but they are not displaying the way I think the user wants.

I modified the scripture text as follows:

\v 35 …\f + \fr 1:35 \fq … \ft … not in focus in this passage. See \w family\w* in the glossary. \f*

Screenshot 2022-07-19 142115

Clicking the word ‘family’ in the footnote has no effect, and I see no change in the appearance of the text (ie. clicked-link).

The glossary for the entry ‘family’ follows:

\c 6
\cp F
\v 1 \k family\k*: …
\v 2 \k fortress\k*:

I made another change to a glossary word, this time in the text, and it works correctly.

The text has been changed to:

\v 24 The commander ordered his soldiers to take Paul to the \w fortress\w* and gave …

and the glossary is:

\v 2 \k fortress\k*: a huge and secure stone building or group of buildings in …

Screenshot 2022-07-19 143256

Screenshot 2022-07-19 143459

Clicking the word ‘fortress’ in the footnote displays the second image, and clicking on the link in the upper right corner jumps to the term in the Glossary, as expected.

Am I missing something? Or is the fact the glossary terms are embedded in a footnote that is causing the problem?


After posting, I see the program formatted my text, instead of showing the actual markers. The word ‘family’ in \v 35 is actually written \w [family](GLO.6.1)\w*, and ‘fortress’ is \w [fortress](GLO.6.2)\w*

Sorry for being slow getting back to you. But your \w mark up is only supposed to be:

\w family\w* and `\w fortress\w*

You don’t put Markdown mark up inside of a \w ...\w* structure. The structure is a link structure without the Markdown.

I’m not clear on what the text needs to have to produce the correct result.

The current text has \w word\w* in both the Scripture text and the footnote. In neither location is there any indication that this is a glossary word, nor does it show/link to the glossary entry.

I checked the Special Text section, and span.k is set to Bold.

Is the \w[...](GLO.6.1)\w* format not used? Or is it used in a different place?

@BrianA the \w markup is designed for in text use not for in footnote use. Have you tried just the markdown style link in the footnote? I don’t have time to test that.

As it is you are wanting a popup from within a popup.