Not seeing current app version in Developer Console after Scriptoria released update


I am trying to update my app in the Play Store, via Scriptoria.

I followed the instructions from this topic:

But I’m not seeing anything about the current version in the Google Play Developer Console. Reasons that I can think of are:

  • I may have forgotten to increment the version code (not the version name/number).
  • It’s only been 7.5 hours since Scriptoria told me it released the app.
  • My app is currently removed from the Play Store (for reasons I explain here).

I have included some printscreens below. What more do I need to do? Do I need to click something in Scriptoria? In the Developer Console I would expect to see version name 9.5 mentioned, not 9.2.4. Once I see 9.5, I’ll feel confident in clicking “Send for Review.”

Thanks so much for your help!

Scriptoria details:

Email notification from Scriptoria:

What I see in the Google Play Developer Console:


Take a look at Fixing Google Play Rejections.

What was the reason for your app being removed from Google Play? Google Play will not accept updates through the APIs that Scriptoria uses. So you have to fix the issue manually through the Google Play console before Scriptoria can be used again for the project.

Thanks Chris for the response.

I read the topic you referenced. However, the rejection was due to a problem with the app itself, not its description.

I explain what happened to the app here, in full:

Do you have any other ideas? Do I need to upload the APK or AAB directly to Google Play this time?


I tried uploading the APK and AAB directly to the Google Play Developer Console but got the following errors.

What should I try next?

Trying with an APK:

Trying with an AAB:

Thanks so much.

For what it’s worth, I’m using SAB 9.2.4. Here are my Android SDK packages:

I ran the following check, but I don’t imagine it to be relevant, as I don’t use Aeneas:


I will be focused on PD during the month of April, so anything unsolved today will have to wait until May.


Good news: the app is live in the Play Store again!

Here’s what was happening:

By default, Scriptoria disregards the Version Code set in SAB and automatically increments the value on its own.
(Documentation on page 4 of this PDF, linked to from Publishing>Publish Properties> Scriptoria Publishing Properties documentation in SAB.)

Sometimes I would remember to increment this code, oftentimes I wouldn’t. But it didn’t matter, because Scriptoria was overwriting that value and taking care of it for me.

When I was uploading my APK directly to Google Play Developer Console, however, Scriptoria no longer had my back. (I didn’t even know that it had had my back!) Google Play was only seeing the value I had set in my SAB project- a value that was much lower. And because it’s not possible for a device to upgrade to a version with a lower Version Code than the one already installed, Google wasn’t accepting the new APK, saying (cryptically), “you can’t rollout this release because it doesn’t allow any existing users to upgrade to the newly added app bundles.”

in SAB the Version Code was set to 6. But from the Google Play Developer Console I was able to view the release history, and saw that the last accepted APK had version code 11.

So once I incremented the version code to 12 in SAB, Google Play accepted the new APK. Then I had to manually send the new release for review. Less than 24 hours later, the app was live again. The download count was the same, but all of the app reviews were lost.

Great detective work, Alex! Thanks for letting us know, and sorry you had to learn the hard way!

No worries. This has certainly been an edge case! :smiley: