Problem recording long lines in parts

When I use the feature for recording long lines in parts, I find that the program is not recording properly. It only records fractions of my voice and the recording sounds like as if the microphone had a loose connection (which it doesn’t because the normal recording mode works just fine). The final result sounds like one of those bad connections on the phone where the line keeps cutting out. Has anyone come across this and with somebody know a fix?

This is in the desktop version, right? (As opposed to HearThis for Android)

Correct, this is the DT version.

I have also noticed this. Initially it seemed to only happen with USB headsets, but I have since noticed that it also happens with the built in sound card. I noticed this back with version 2.0.104 (or earlier), and just noticed it again in version 135 with a non-usb mic.
Every time I have seen this problem, it has been with a Dell Latitude laptop, but with several different models.
Is there any update on this problem, or any workaround? Thanks

I found and fixed a very definite problem in this area a month ago, but that fix is in 2.0.135, so if you’re still having it, it’s something else.
Quite a few people have reported a variety of recording problems, but it’s difficult to know which ones are actually the same problem and which ones are different. It is also very hard to know when a problem is specific to a machine or a particular hardware/software configuration. Since you seem to be having the problem on multiple computers, it seems less likely to be caused by a particular configuration.
Can you send a sample of a problem recording to In your case, are you hearing the problem in the two individual recorded parts or just in the combined version? I assume that you are able to record okay using other software (and also using the main screen in HearThis)? Some people have found that when using an external mic, it is best to disable the built-in mic. I think he fix I did last month should have made that unnecessary, but I haven’t gotten any reports from the field to confirm this.

This topic seems to be related: Sound glitches in HearThis 2.0
Can’t be sure how many distinct issues are involved, but I’m putting think link in here so users can cross check and see if there’s anything potentially useful in the other topic.

Yes, this was the same issue as in the other link.
I am on a different computer right now, and didn’t save the audio files, as they didn’t record right, but here is what I noticed.
I recorded both of the lines, and then listened to the combined lines. When I listened to the combined, only the first half played, and it sounded ok. I then checked the segments, and part 1 was good, part 2 had missing audio. Playing the combined, it just skipped the second part.
This time, I was using a standard mic (headset mic from Dragon Naturally Speaking). I will try to duplicate the problem later, and send you a copy of the files. I will also try disabling the internal mic, and see if that makes a difference.

The other diagnostic step that would be really useful would be to run Task Manager and watch CPU usage when opening Record in Parts and also when you start recording with HearThis. If it hovers near 100%, that’s the problem. (That was what I noticed before when I discovered the bug that I fixed last month.) If HearThis is responsible for most of the CPU usage, then there’s obviously still a problem. If there are other apps sucking up the CPU, then try shutting them down and see if that fixes the issue. It’s just possible that there is a backup or disk management program causing a problem, or maybe a bunch of apps all doing their part to put the machine over the top. And of course, there’s always the possibility of malware, but given the nature of the problem, I wouldn’t assume that.

Hello Tom,

I was going to post a new topic on this issue but found this old thread. I am using the latest version 2.0.137 and having the SAME issue. When recording in parts, the first line records fine. Every time the second line ONLY has an issue. It sounds like it is cutting out in parts. I checked my CPU usage as per your response to bhigham, and I don’t notice it taxing my system while recording in parts. Do you have any other suggestions?


Is this happening using a USB mic? What brand/model? Can you try it with the built-in mic or a simple 1/8" (3.5 mm) mic? Given that it is happening only when recording part 2, it almost certainly has to be some sort of a bug in HearThis. I would dearly like to get it fixed, but I’ve not yet been able to find the problem and I might not have much more time to work on it this month.


Yes, A usb Yeti mic. I tried the built in mic on the laptop and it did the same thing. Although, not long after I wrote this post, it just started WORKING. I didn’t really do anything. Just started recording fine. So strange. I did notice that periodically there would be load pops that would show up in the recording and I’d have to rerecord the line. Anyway, not specific or helpful feedback for you, but I’m happy that it mostly worked out! Thanks for being so attentive to these forums.


Glad it’s (mostly) working. We’ll continue to monitor the forum and see if we can eventually determine what it is that is causing issues for some people when recording part 2.