Problem with Parallel References (\r) popup window

I built an Android app with the Mac version of SAB 7.1. Most things seem to be working fine. However, here is a screenshot from the app. Situation: I have clicked on the \r field (Parallel References) under the heading. The parallel passage pops up in a little window showing a preview of the passage. Here are the problems:
a) There is the word “null” instead of the verse number(s).
b) The preview shows the beginning of the (correct) chapter, but not the correct verse(s).
c) If I click the arrow-in-a-box, I am taken to the correct book and chapter, but not to the correct verses.
This may be a bug, unless I have some settings wrong. Any ideas how I can make this to work correctly?

Hi Iska, I have not seen this before so I’m not sure what is going on (so no promises!) but if you would put your folder on a Google Drive/OneDrive online storage and send me the link via message here (click on my avatar and click Message) I can take a look at it.

Iska, got the project - from what I can see this looks like it should work. I have worked with Arabic script but never with the Persian numbers (١٢٣), always Arabic numbers (123), so this is the first time I’ve tried with this number system, so I could be missing something.

When I put the reference in with Arabic numerals, it does work a bit better with everything else the same, but switches up the chapter and verse numbers in the target URL (It’s supposed to go to 42-LUK-003.html but to tries to go to the non-existent 03-LUK-003.html - and 03 is the number of the chapter) so I think there must be something SAB is missing (unless it’s me that’s missing something).

I will put a bug report in for the developers to look at on this.

Hello Corey,

Many thanks for your time and effort and for creating the bug report.

Just out of curiosity I checked our old version of this same app, which was published in the Play Store over a year ago. Here is the same screen shot done with that app. It appears to work without any issue. Looks like something is broken in the present version of SAB.

OK thanks for that - will include that in my note to the developers.