PWA html export settings in SAB 7.0.1

I have downloaded SAB 7.0.1 and am hoping to explore the option of a PWA.
In this dialogue box I cannot tick the ‘Include Progressive Web App files’ box.
I have followed the links and downloaded everything. What else do I need to do?


Sorry that I have not gotten to documentation on this yet. And today is a busy day at home (Medical appt in the morning and 18th birthday for our oldest).

You have to install npm and workbox-cli using npm. Once everything is installed, then the check box will be enable. You may have to restart SAB in order for the change in the installation to take affect. I can test that…


Thanks Christ and wish them a Happy Birthday!
I believe I have installed the workbox-cli using npm. I have restarted my computer and I still can’t click it.
Maybe we can chat later or tmw. No rush as I am leaving any SAB 7 features for a future update.

We fixed the issue. There was some problem with installing the workbox command line interface:
npm install workbox-cli —global

We had to clear the cache:
npm cache clean —force


To install npm download and install NodeJS from here:
For me I’d pick the Windows msi installer for 64bit.

Once that is installed.
Then bring up a command prompt. (Click on the Windows (start) icon and type command prompt and press Enter.)

copy the and paste in:

npm install workbox-cli -global
  • Close SAB if it is open and restart SAB.
  • Go to the Collection you want to export.
  • Right click on the collection.
  • Select the Export to HTML settings
  • Select the Progressive Web App tab.
    • If this tab is not visible do the step Clear Cache below.
  • Check the Include Progressive Web App Files
  • Enter the Name and the Short Name
  • Click OK
  • Go back to the collection and right click.
  • Choose Export to HTML

Your PWA files should be in the export folder.

Clear Cache

If you have problems you may need to clear the cache with:

npm cache clean -force

Then retry the first command.