SAB 4.7 MAC Manual Problem and Install problem

I get stuck because the manual is not up-to-date with the iTunes menus

10. Using iTunes to Test an iOS App
To test your iOS IPA file using iTunes, do the following:

  1. Connect an iPhone or iPad to your Mac using a cable.
  2. Launch iTunes if it does not start automatically.
  3. Click the device icon on the toolbar at the top left of the iTunes screen. You will see information about your device and what is installed on it.
    4. Select the Apps menu.

At this point 4 I get stuck now, because this APP menu item has been removed by APPLE.

Please can you send me an updated instruction in your reply … and insert that also in the SAB manual?


Yes the documentation has been updated for the next release. iTunes in not an option for up-to-date systems. I have used the following and had no problems.


Using Xcode to Test an iOS App

To test your iOS IPA file using Xcode , do the following:

Launch Xcode and select Window Ø Devices and Simulators .

Connect an iPhone or iPad to the Mac using a cable and unlock the device.

On the Mac, iTunes may launch and show a dialog asking “Do you want to allow this computer to access information…” Click on the Cancel button.

Note: This feature can be turned off in iTunes. Select iTunes Ø Preferences… , select the Devices tab, and click on the Prevent iPods, iPhone, and iPad from syncing automatically checkbox.

On the device, it may prompt to Trust This Computer . Tap on the Trust button. This may require to enter the Passcode to trust this computer. The device will show up in the Xcode Devices window.

The first time the device is connected to the Mac, Xcode will take some time to Prepare debugger support. This may take some time. Please wait.

In the Xcode Devices window, there will be a section named INSTALLED APPS . Click on the + button.

Find the IPA file to add. Click Open after you have selected it.

Click the Install button next to the name of the app.

Wait until the Mac installs the app to your device.

After the install is complete, you will see the app icon on your device and you can test it.

Yes, that works - thank you - BUT what if - when I start transferring the IPA file to the iPad - it can not complete that process and the messages appears

App Installation Failed

?? Oef!

After this we continued to App Store Reconnect - see the other post regarding the problems there!

Did you try the app on a simulator before loading on your phone?

We tried to get it on my iPad BUT because there were problems, and because we discovered that this Production App should not necessarily be transferred to a testing device, … we decided to start immediately bringing it unto the store though to the App Store Connect to see if that worked … then we got this message ….
Regarding your question about the Simulator … it used to work all the time, but you made me think … I did not try after I fixed my provisioning files (at least my intention was to fix it)) but after your remark I tried it again, but now I cannot get the IPA working on the Simulator anymore … when I click Launch (after Build), there is no movement nor message at all, the App simply does not come up in the Simulator …

In the Signing iOS TAB I see 3 headers:
(1) Signing identity (provided by Keychain and renewed this month) and (2) Provisioning File made under my Dev. License this month and (3) Profile File Properties … with Type : appstore’s, AppID and Team Id and Devices (none) …
The Profile File properties are they generated automatically … how?

ADDITION: I redid my certificate and profile, but I get the same errors when we upload to Apple store Reconnect. I checked SAB and found that under profile File Properties no mention is made of a Device, though in our Developer Account we have added an iPad. I am not sure if this is normal?

Is there a bug … when I start the Simulator it does appear on my screen, but the button START is still highlighted in Blue … normally it turns back to a normal grey meaning the process was completed.
When trying to click Build or Launch nothing happens …


I have exactly the same problem with those exact details. I tried to follow all the points of SAB 5 manual (and everything seems ok as said in the manual) but, in the end, it does’t work. Simulator starts well but, then, window gets stuck with blue “start” button…cannot launch. Xcode recognises the iPhone but cannot install. It gives error Even though I have created ad hoc provisioning file with my iPhone ID it cannot be recognised by deploy. It says my iPhone ID is not in the provisioning file (even though I can see the ID when adding it to SAB). I have tried to add it as a txt file as suggested by deploy

but in Apple developer it says the iPhone ID is already registered and included. In Android everything is ok, but not in Mac. Please…can somebody help me? I am new to Mac.

This is the distribution provisioning file

I have macOS High Sierra 10.13.6. SAB 5, Xcode 10.1 and iPhone 6 with IOS 12.1.3

It looks like when you created your Provisioning Profile you did not add any devices for testing.

I have not made an app for the appstore. But my debug profile shows a number of devices listed under Devices.

Version 5.1 has been released. Though I don’t think that will fix your issue.

FYI, for testing with the Simulator, you don’t need the iOS Signing configuration.

If you are having issues with the Start or Launch buttons in the Run iOS Simulator dialog, these are just convenience buttons to launch the simulator, install the app, and run the app. You can do this without using the dialog. You still need to use the dialog to build the app.

[Note: If you have the iOS Signing configuration and use the Build iOS App button, it also builds the app for the simulator at the same time.]

To start the simulator:

  • Open Spotlight search
  • enter Simulator in the search dialog and press return to launch it

To install the app:

  • make sure to run Build from the Run iOS Simulator dialog and close the dialog
  • Use the menu item File -> View Simulator Output Folder ...
  • Drag the build app to the simulator (this will install it)

To launch the app:

  • Go to app launch screen and launch your app

Thanks Chris for your answer. I was able to run the app in the simulator by dragging the file into the simulator. I was also able to run the app on my iPhone. When I installed Fastlane I had no bash file and I did not create it…I did not know how to create it. So it did not run when compiling the app and the app was not signed correctly.