SAB 6.0 does not Open

SAB 6.0 does not Open
If I uninstall Java (Corretto) and double click SAB, Windows asks how to open.
If I install Java (Corretto), the cursor goes to the busy symbol, and then stops.
Is there a way to get more information? The event viewer shows no errors.

This is happening on 2 different laptops, but other laptops are fine.

On Windows JAVA_HOME environment variable should point to the location of a Java JRE or Java JDK. Then in the Path environment variable you should add the path to javaw.exe.
On my machine this could be one of three places:

  • C:\Program Files\Amazon Corretto\jre8\bin
  • C:\Program Files\Amazon Corretto\jdk1.8.0_212\jre\bin
  • C:\Program Files\Amazon Corretto\jdk1.8.0_212\bin

You only need one of the above. Do not have two different places, that will cause you problems.
If that is not enough then something will have hijacked the file association for .jar.

  • Go to the file C:\Program Files (x86)\SIL\Scripture App Builder\bin\scripture-app-builder.jar
  • Right click and choose Open with . . .
  • If it says the default is OpenJDK Platform binary that is good.
  • If not then choose More apps to look for that one
  • Also check the box Always use this app to open .jar files
  • If no OpenJDK in the list go to the bottom and choose Look for another app on this PC
  • Now navigate to the location of your javaw.exe.
    SAB after a bit of time should open.

I also use the registry to fix problems but that is more complicated.

I have seen .jar files associated with Adobe Acrobat, WinRar, Zip Extractor.

Resetting Win10, and reinstalling everything did not fix the problem.

I checked the path, JAVA_HOME and and the default app for *.jar files. Everything looks good.

I even created a new Profile on one system, nothing opens when double-clicked.

A/V is removed and Windows Defender and Firewall are Disabled.

java -version gives the expected answer.

Same thing with SAB 6.02, and RAB 6.01.

Removing Corretto 8.212.04.2.1, installing 8.222.10.3 fixed the issues. No idea why?

Thanks for keeping us all in the loop. So glad it is fixed now.

Hello Mike,

I am trying to run 6.2.2 and I have installed the suggested Amazon JDK but the SAB .exe (which I found out was a .jar) won’t open. I’ve checked that it is trying to open using the “javaw.exe” found in the jdk folder. The batch file works for opening but I’m trying to figure out what’s going on. Thanks for any other tips you can give,

-Casey

So you are saying if you go to the SAB.bat file it starts okay?
But if you click on the desktop icon it does not work?

This generally happens if another program has been associated with the .jar file.
If you open a command prompt and type in:

reg query HKCR\.jar

What do you get?

I get:

HKEY_CLASSES_ROOT\.jar
    (Default)    REG_SZ    Corretto.JarFile
    Content Type    REG_SZ    application/jar

I am guessing your (Default) entry does not say Corretto.JarFile

Though registries can point to intermediates.

Yes, that’s correct. I get:

HKEY_CLASSES_ROOT.jar
(Default) REG_SZ .jar_auto_file
Content Type REG_SZ application/jar

But when I open my “default apps by file type” in windows, it says that .jar files open by default with “OpenJKD Platform binary”. I tried to change the default to the javaw.exe but the only options I get in the choose default list are Excel, and “look for an app in microsoft store”. I can’t navigate to the javaw.exe file.

I’m also having a problem with running an install of RAB on a colleague’s 64 bit Windows 10 machine. I cannot open RAB from the RAB.bat file. I tried the latest version of Corretta as well as the older 8.222.10.3 version that MikeB said worked for him. I didn’t yet try a registry repair. This would be somewhat complicated, because I’m trying to get RAB running through a Zoom screen share, and I believe a registry repair requires restart and preference selections. @mcquayi have you often found registry repair to be helpful?

Btw… I’m also getting (Default) REG_SZ .jar_auto_file when I type “reg query HKCR.jar” into a command prompt. I’m not sure how I would make the default Corretto.JarFile

Thanks

If I query: reg query HKCR\.jar
I get:

HKEY_CLASSES_ROOT\.jar
    (Default)    REG_SZ    Corretto.JarFile
    Content Type    REG_SZ    application/jar

Then a query of: reg query HKCR\Corretto.JarFile\shell\open\command
Produces:

HKEY_CLASSES_ROOT\Corretto.JarFile\shell\open\command
    (Default)    REG_SZ    "C:\Program Files\Amazon Corretto\jdk1.8.0_242\bin\javaw.exe" -jar "%1" %*

If you correct the first one to point to Corretto.JarFile, that should be enough.

I edit via RegEdit. You probably can do it via the command line too, but that is more scary.