SAB 6.1 RTL search iOS finds no results

Searches work fine on Android, but on iOS, I mostly get no matches found, even with “use whole words” unchecked and copying and pasting words from the verse text. This is with text in an RTL script.

Has anyone else encountered anything like this?

I think the problem is that because it is an RTL project, SAB inserts a character in there to right justify the edit box, but then that character causes the match to fail. If that character is manually deleted, the search works.

@Dan_Em,

Would it be possible to for you to do a screen recording of manually deleting the character? I don’t understand.

Thanks,
Chris

Thanks, @ChrisHubbard!

Here’s how it looks when you first click to open the search screen. The insertion point is all the way at the right edge, actually outside the white box. The word “search” is not visible. Match whole words is ON=RIGHT. Match diacritics is OFF=LEFT:

Before we enter a search term, we must click the DELETE button. Once we do so, the insertion point moves to the left of the edit box, and the grayed word for “search” becomes visible:

We enter our search term, and turn “match whole words” OFF. The green is removed, but now OFF=RIGHT for this control. (Clicking it again would make it ON=LEFT.) The second toggle is still OFF=LEFT.

We click the RETURN button, and the search is performed. (Yay for the iOS version! The Android version inserts a newline in the search box instead.)

If we click the BACK arrow, the search term is left-justified. The keyboard is not visible, but the “search” button is. If we clicked it, the search would work as before.

However, if we click in the edit box, the search term is now right-justified (slightly off the screen, in fact), evidently because it’s had an RTL marker inserted at the front. Unless you have a physical keyboard, there is no way to delete that RTL without deleting the entire search term, because you can’t move the insertion point by clicking elsewhere:

Now if we click RETURN, the search fails:

At this point, iI’m not sure what the white box is for, but if you click it, the app crashes completely.

I tried to get SAB to ignore the RTL character by adding \u200f to the characters to ignore, but I couldn’t get it to make any difference. However, the other substitutions there didn’t work either, no matter how I toggled the second toggle:
25%20AM

There are also some other glitches with the Keyman keyboard, but they are not the same across all devices:

  • On some devices, the rightmost keys are drawn at about half-width. The keys do not occupy the full width of the screen, but leave some unused margins.
  • On some devices, touching the screen at the rightmost keys gets no response; you’d have to press on the keys to the left to get the rightmost column.
  • Sometimes the keyboard simply never appears. When it gets in this mood, there is no way to enter a search term; starting over doesn’t help.

Any help with these issues would be most welcome. Thanks!

@ChrisHubbard, will the above do for reporting bugs, or should I report these issues somewhere else?

@Dan_Em did you get any additional feedback on this? Realize it was from over a year ago but I’m testing an iOS app in TestFlight now and one of my testers mentioned this issue…at least of finding no results and crashing when clicking the “white box”.

Yes, that bug is still present. If there are no results, a white box is shown. If you click the white box, the app will crash.

Not an RTL issue. If you click the white box when no results are found, this crashes. Corrected the issue which will be available in the next release.

1 Like

Thanks for this feedback! Good to know the bug is being addressed. Can you give us an estimate of when this bug fix will be released (when the next release is targeted)?

Should be sometime in May.

1 Like