SAB crashing on Desktop won't start


My old Macbook is too old to be upgraded to High Sierra or Mojave, so in order to update my iOS app I’m trying to update it via a MacOS Mojave VPS (hostmyapple). After installing latest version of SAB 5.4 and java 8 I tried opening SAB and it wouldn’t open. Each time it crashes (“unexpectedly closed”). These are some of the contents of the error report:

Process: JavaAppLauncher [1282]
Path: /Applications/Scripture App
Version: 5.4 (5.4)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: JavaAppLauncher [1282]
User ID: 508

Date/Time: 2019-05-20 08:11:20.090 -0400
OS Version: Mac OS X 10.14.5 (18F132)

Crashed Thread: 30 Java: QuantumRenderer-0

Exception Codes: KERN_INVALID_ADDRESS at 0x000031a6f24ff7f8

VM Regions Near 0x31a6f24ff7f8:
VM_ALLOCATE 00000007c0300000-0000000800000000 [ 1.0G] —/rwx SM=NUL
MALLOC_NANO 0000600000000000-0000600008000000 [128.0M] rw-/rwx SM=ALI

Application Specific Information:
abort() called

Any recommendations? The VPS has 2GB of RAM, should I try to increase it to 4GB or RAM? I tried downloading an earlier version (5.3 and the same thing happened).



Full error report is here: drive google com /file/d/1NydGHWbzw3k-5emLVcVX_dTDGGeaGraY/view?usp=sharing

(I’m a new user on this forum so I can’t post full links)

@vanderling I am not sure if we can support you on this platform. Let me check with an iOS expert.

Are you making Android or iOS apps or both? If only Android, have you thought of running a VirtualBox virtual machine with Wasta Linux as the OS? You can use the package manager to install all the software.

Thanks for the reply. @mcquayi. I understand it’s not a typical scenario. I’ve already updated the Android app of this Scripture (play google com/store/apps/details?id=com.yyy.hadi&hl=en_US), but as you know an iOS Scripture app needs to be created on Mac. I wish it was possible to create Mac apps on Linux, since I run linux on my main machine. Maybe someday Apple will play nice and be a bit more flexible : ).

@vanderling, that is very odd. SAB for Mac includes the JRE so it doesn’t require Java 8 to be installed (which would only be needed for building Android apps). If you are building just iOS on this Mac VPS (which I didn’t know existed), then you need Xcode and Fastlane installed (see installation documentation).

It looks like they are using VMware server on a host Mac to be able to do VPS. The closest thing to that that I have is a Parallels VM. I am setting up a Mojave clean install and will try to test SAB 5.4 on that.


I have reproduced the issue in my Parallels VM (odd … it works fine on my desktop which is running Mojave).

I updated the JDK on my machine and rebuilt SAB (which would include the new JRE in the SAB application) and it launched correctly on the same Parallels VM.

Unfortunately, our build service is down at the moment so I can’t make a re-release of 5.4. Here is a work-around.

Download and Extract and do the following:

  1. Find Scripture App Builder in Applications folder

  2. Right-Click (or Ctrl-Click) and select Show Package Contents

  3. Double-Click on Contents folder

  4. Delete Info.plist file and Plugins folder

  5. Copy Info.plist file and Plugins folder from the extracted zip file into the Contents folder

  6. Go back to Applications folder and launch Scripture App Builder

This should work for Reading App Builder or Dictionary App Builder as well.

UPDATE : I changed the link to zip file using Amazon Corretto instead of Oracle Java SE.

1 Like

Thanks @ChrisHubbard , I noticed if I comment out the following lines from the /Applications/Scripture App file, I’m able to open the SAB program without it crashing:

I’m also stumped why this is an issue on Virtual installations. Also happened on my Virtualbox install. Thanks for looking into it.

@vanderling, I suspect that problem might be fresh installs of Mojave (i.e. not upgrade installs from a previous versions). I am trying to do a fresh install of Mojave onto a USB drive and will report back.

@vanderling, I tried this on a fresh install of Mojave on real hardware. There wasn’t a problem with startup with the real hardware. The only thing I can guess is that there was a problem with the embedded JRE and VMs that has been fixed??

By the way, the zip file like I have you had the newest JRE from the newest Oracle Java SE 8 which is using the newer license. Please redo the replacement using this zip file that was created using Amazon Corretto (free version of Java based on OpenJDK).