Some links from a Word document not working

I have an article in a book collection and it has many scripture references. In Word I have made each reference into a hyperlink to open that language’s Bible app to the said verse. (this is a separate app)
Almost all of them work but there are a couple that will not work.
Most are on a line of their own so it is easy to see in the Source that there is no hyperlink:
\s2 (یۆحەنا ٨: ٥٨)
as opposed to:
Screenshot 2021-10-14 at 12.42.13
In Word, both are created the same way and look the same. In Word you can click on both of them and you get the same result, it opens the website. In Word when I click on the link button under the Insert tab, it shows the desired hyperlink correctly.
I tried copying one that works correctly and replacing the non-working one, it then stopped working. The I tried copying and pasting it above and below the non-working one. Then the one that wasn’t working, which is now in the middle started working and the one on top wouldn’t work.
With enough fiddling with copying, replacing and deleting I got that one to work then a separate one from a previous paragraph stopped working!
What is causing this?
I could spend all day trying to fix it but I have a lot of articles that I am planning to put in the app so would like to find the root of the problem.
Any suggestions?

@CraigN Please can you send a sample document to the Support team so that we have something to use to reproduce and fix the problem. Thanks.

Thanks Richard for your reply. I re-did all the links and now they all appear as they should in the Source tab and the links work in the Viewer tab.
I had originally copy-and-pasted the text from a document sent to me by the translator where the English and Kurdish were in separate columns on a table. Doing this sometimes leaves residual problems that can’t be seen with the naked eye (normally RTL issues, but sometimes confusion between the letters ە and ه which I know look the same here but are different when connected to other letters).
I don’t know what happened, but when I got back from holiday and opened the .doc file none of the references had links. Maybe I had decided to start from scratch before I left and deleted them and I forgot about it, anyway I added them and they work now.
Bizarrely, now the book won’t appear in the app. Here it is in the book collection, at the bottom:

But when I build the app, it doesn’t show up:
Screenshot 2021-11-01 at 12.35.49
Any idea why this might be? The other 3 are there, I have tried deleting it and adding it again.

Good to hear that the link are working again.

Regarding the book not appearing, is this on the Contents menu? If so, you need to make sure there is a corresponding menu item on the Contents menu to link to the book. When you delete a book, its menu item is removed.

1 Like

Thanks, I had forgotten that I was looking at a Contents Screen. I was getting that confused with the drop-down menu.

I have come across the problem again so will send the .doc to your team.