Space between Keyword en Footnote Text

I find that my keyword which is in BOLD is immediately connected with the footnote text which always starts with a hyphen, so it looks like thugs:

keyword- a word that is explained in the footnote text.

You see that the hyphen sticks to the keyword, but there should be a space. Is there a setting in PTX Print where I can set a space …

By the way I am new on PTXPrint and I run it on Mac with CrossOver which does not require a Windows version to be installed, but only the PTX Print according to Crossover instructions. It seems to work ok, so far, at least it is very workable.

It sounds like an issue of how the text is marked in Paratext.
\fk keyword \ft -
Should be the proper way to mark the text.
If you have:
\fk keyword\ft -
then there will be no space between the keyword and the hyphen.
In Paratext most markers are ended by a space. This means that if you actually want a space you add one before the marker.
The exception to this rule is markers that end with an asterisk. (for example: \wj* or \f*). For these markers the * actually ends the marker and any space afterwards is a true space.

Thank you Phillip

Right, but my sfm does not come from Paratext but is made very similar by a script.

This works fine in SAB, the space is there, but not in PTXPrint, so should I ask for a New Feature: manipulate the distance between Keyword and FNText?



I’ve just done a little test, adding this line to a file:

\f + \fk test one \ft - Hmm\f* \f + \fk test two\ft - no space\f*

And I can’t make the first one to behave as you are reporting once you get to the XeTeX level (the part that turns USFM into PDF), so it’s not a problem there.
There are some possibilities remaining:

  1. PTXprint (python code) is removing the space
  2. You have a line in changes.txt file which is removing the space.
  3. You are using a special character which does not behave as a normal space or a normal letter (and so my ASCII minus did not test things properly).

If you want to dig a bit deeper, you could look in the local/ptxprint/[project-name] directory (your slashes may be the other way) under where your USFM files are. In there you’ll find lots of things including the re-written USFM file(s) that is/are fed to the XeTeX job. You could then look at them to check to see if your space is still there, between the keyword and \ft. If it is, then my guess is (3), and I’d be feeding that line of text to something that tells me unicode values for each character.

ps. I’ve just put the above test line through the whole PTXprint process (this particular test run clearly paragraphed the footnotes):


So, IF you are using a simple U+002D HYPHEN-MINUS, with normal spaces, then (1) above is unlikely.

I hope this helps you track down the issue. If not, then you can create an archive (see the help tab within PTXprint) and submit it by email to the address listed there, (referencing this topic).

This solved the problem, a few days ago, when I inserted the lines below in change.txt …
sorry I did not report this back … and thank you for your efforts on this!

REMOVE spaces before footnotes and cross-refs so that they don’t

get detached from the word and end up at the start of a new line.

" \f " > "\f "
" \x " > "\x "

But ADD the space which should be there before the \ft marker

" ?\ft" > " \ft"

The above works fine.