Text appearing after a long wait (HUAWEI & Samson models)

In the last month after the last 2 updates I have found our Bible app has been taking ages to appear in Huawei nova 2i Android version 8.0.0; Huawei GR5 2017 Android version 7.0; Huawei G8 Android version 6.0.1. Samson Galaxy S2 phone is the only phone which it isn’t having any troubles.

Previous versions it ran fine but after the second last update for SAB compiler on linux the apk now produces problems on these phones when the Bible app are initially opened up. It seems it takes 15 seconds for the script to appear. This wasn’t happening in previous versions. I haven’t been able to try out any other phones. The screen shots shows what happens when Mark chapter 3 is opened (sorry I am only permitted to upload one image). The first shot is blank screen for 15 sec then the script appears. If I move to a new chapter the same thing happens. It takes 15 sec for the script to appear.


Are you relying on System fonts or are you adding your own fonts? If so which font?

My fonts are embedded within the app. TCRC Youtso Unicode.ttf.

I have been updating our app for the last 3 years and it has been working fine over that period but in the last 2 updates something has changed. It seems as though it is buffering something. I see a circle on the screen and dot going round and around the circle for about 15 sec. Then the script appears and the dot going around the circle continues. During that time you can’t move within the Chapter that is open. When the circle and dot disappears then you can move within the chapter. You can move to a new chapter without any issues. But if you move to another new chapter then the script takes forever to appear and the circle appears and the dot appears which moves around the circle. It reminds me of something being installing or buffering something.

I’ve just confirmed this issues occurs in Samson android phones in addition to the Huawei phones. Galaxy S9 Android 9; Galaxy J5 Pro Android 8.0

Moto G Plus Android 7.0 has a lesser of a problem than the Huawei and Samson phones. It brings up the fonts quicker but not as fast as I had it coming up on my Huawei a month ago.

Can we get a copy of the app to look at?
Could you test with a different font like the Google Noto font? Then report on if the same thing happens.

If you don’t want to make the app public you can send me a private message by clicking on my icon and select message.

How can I send you the app. I tried to put in a hyperlink to the Google Drive so that you could download it but the website said new members to this community can’t place hyperlinks in the message.

I also tried clicking on your icon but there was nothing there to select message