Unable to build APK or IPA on Mac

Haven’t used SAB in more than a year. After upgrading to latest version, I added some books, some audio and created timing files. However, whenever I go to build either the Android app or iOS app, a dialog comes up saying its writing the files and then the dialog disappears and nothing else happens. In the past, a terminal window would appear when the actual build would happen, but now no terminal window comes up. I’ve reinstalled SAB, restarted my computer, but no change. Anyone got any advice for me on this?

I’m not entirely sure what the problem is but I’m pretty sure that you need to create a new signing certificate for iOS apps and you may have to update Xcode as well. But this doesn’t explain why you can’t create an Android app…

When I first tried to build the iOS app, I did get errors that the signing certificate and provisioning profiles were wrong, so I recreated both of those. The error, or lack of error, that I’m describing above happened after that. And like you said, Xcode/signing errors shouldn’t affect my ability to build an Android app. It seems like there is a common error affecting both.

I see. Regarding Android, did you check if the SDK installation is up to date? You need to compile for Android 11 now. So you may want to check SAB > Preferences > Android SDK. It should look like this (although this screenshot is from SAB Windows)


I have all of those build tools updated already.

It seems to me that the problem is not a settings problem, otherwise I would be getting an error of some sort that my build tools or certificates were incorrect. The lack of any error at all leads me to believe there is some problem with something on my system, but I’ve tried to remove things and reinstall with no effect

I found the issue! The tmp directory used for building the app was a nonexistant folder, thus the app couldn’t write to the folder and would fail. Fixed the tmp folder and it works as expected.
Seems it’d be pretty easy for the app to check to make sure the build folder exists/is writable before attempting to build.


Was it the Build Folder setting? Normally that is created by SAB using the $TMPDIR environment variable and then appending “/App Builder/build”. Did you change the value? I am curious why this would fail to work.

Yes it was the build folder settings. When I looked at it the value was formatted “/var/folders/xx/x_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/x/App Builder/build”. Ran “echo $TMPDIR” in terminal and saw that the value was different than the one in my build folder. I created a directory in my Documents folder and set that as the Build Folder and it ran fine. Afterwards I went back and cleared the Build Folder setting, clicked OK and when I reopened the dialog it had populated it with the current $TMPDIR setting. I assumed the app knows to retrieve the new value every time the app opens, since that value can change sometimes after the computer is rebooted. However, for whatever reason it was failing to do that on my machine.