Verse of the day Image create issue

Hi SAB Team,

I create verse of the day image default images appears correctly.

When I create custom in my phone image selected

Next option is cropping the image which I selected. Here not showing.

Last week it’s was worked perfectly. Yesterday onwards this issue I am facing. I don’t know whether it is Bug…

Which version of Scripture App Builder did you use to build the app? A quick current test, using 9.0.1, works fine for me. I assume you’re seeing the same blank screen whichever picture you choose. Is that correct? I would restart the phone if you haven’t already, and try one of the included images again to compare. Perhaps you’ve done all that already…

Hi Andrew_Shafe,

Thanks for your reply, I am using SAB 9.0.1 the latest one. I restart my phone and try to select image it will select image.

next option is cropping the image it seems like this.

Here not showing selected Image.

Please help me in this regards.

Have you tried your app on several different phones to see if any work? If you can, could you post your project somewhere for me to get and try? You can email me at andrew_shafe@sil.org

My app users are also facing the same problem.
Kindly resolve it in upcoming version, please.

@C_Thiyagarajan, @Raja_Sand This kind of error is likely to be Android device and version specific, so we will need some more information, please, in order to track down the problem:

  • On which versions of Android are you seeing the problem?
  • On what makes of devices?
  • Are you able to retrieve the “logcat” error log from the device, containing more information of the error that was produced after selecting the image?

Hi Richard,

I have try to create custom image in my android version 11 phone it is occures same issue earlier I have mention.

and also tried another android version 7.1.1 it’s working fine.

That’s interesting. I have an Android 11 phone and the custom images are working fine, so there must be something else happening. If you are able to retrieve the “logcat” error log for the phone, that would be helpful.

Hi Richard,

Where to find the “logcat” error log on my computer or phone.

Here is a YouTube video that explains how to capture a logcat:

Hi Richard,

Thanks for your guidance, I have to rebuild the app and tried. Now it is working.

What did you change to get it working? It is good to explain here in case someone else run late into the same problem. Thanks.

Hi Chris,

When I build it the first time the app was working properly. After some time later it is not. I just rebuild it again and tried it is working. Nothing I have changed in SAB I don’t know what happen in between…

But this is not a solution…