Cross reference not working

Hi, Thank you very much for this wonderful software. We are using it and are very happy.
The cross references in my app are not working properly. I do have \xt_…\xt* for the references. But, only the chapter and verse numbers are underlined in the app. The reference settings in Paratext and SAB are the same, i.e., book name is followed by comma, no space, and chapter and verse are separated by a colon (:). If needed, I can send you a file.

Are you able to post a screenshot of your app showing where you say ‘only the chapter and verse are underlined’? For this screenshot reference example can you also show us the source text (ie. the line \xt…\xt*). Thanks.

That is an unusual cross-ref parsing with book name followed by comma, no space, and chapter and verse. Perhaps the comma following the book name is the issue.
Matthew,1:1; John,12:24-25

It would be helpful to see your .appdef file and a screen shot off one of the xref that is not working.



Thank you very much for the speedy response all who wrote to me. Sorry, I made a mistake in my request. The book name is followed by full stop, not comma. Please see the images below for the screenshots of PT file and Bible app page. This is in Glossary. I wonder if this error is happening because of the Glossary. Should I have \xo … \xo* somewhere?

Another error is that from the ‘1129-1126’, ‘9-112’ is highlighted as if it is xref.
When I press on these half-highlighted xrefs, it is jumping to very random places in the Glossary. There seem to be no recognizable pattern.

Thank you very much for all your help.

Hi mcquayi,

Here is the file. I hope it will be attached here.

Bible MSV.appDef


The USFM User Reference (available from a link on the Paratext site) shows the following cross-reference format:

Your citations don’t begin with \x.

Hi Ed,

If I put \x, what should follow? This is a reference under a keyword in Glossary. Should I use \xk_? If \xo_, what should be the origin reference in this case of Glossary?


Oops. I didn’t notice that you were building a glossary. I just checked the USFM stylesheet and didn’t find anything comparable to references from a glossary back to the scripture text.

Hi Ed,

You are right. The problem might be a lack of such reference in USFM. Actually, this is not a cross-reference where one Scripture portion is referring to another Scripture portion. But, it is a reference from extra biblical book to a Scripture portion. I tried \r_…, then it treats it as parallel passage and puts it on a separate line.


Will this workaround do the job?

(Mat. 1:7 \x + \xt Mat. 1:7\x*)

This needs a copy of the reference, followed by a hyperlink.

Hi Ed,

When I tried your suggestion, this is what I get. It creates a footnote with the reference. When the reference in the footnote is clicked, another window comes up with just the chapter and verses underlined. The problem is still there.

Ref as x error 1.png

Ref as x error


Hi @Bayar_Garam. If I understand correctly, the result you want to see is the book, chapter and verse underlined; when you click on it, a popup showing that Scripture passage appears. If this is correct you can completely remove the \x \x* convention - you only need the Scripture reference (making sure that the book abbreviation and syntax are correct, otherwise it won’t create the link).

Here is an example of a glossary with popup links (screenshot of app and source text):

Hope this helps.

Also, it could be that you are running into problems because your book abbreviations have periods at the end of them, and no space before the chapter/verse reference.

Dear NeilZubot,

Thank you! I added space after the book abbreviations and removed the \x \x* markings. It solved the problem for many cases. However, I still have some cases where only the chapter and verses are highlighted (pls see the images). The problem seems to reside with books like 1Kgs, 2Kgs, 1Chr, etc. where the book name starts with a number. Sometimes, no-number book name has a problem (e.g., Gen). But, sometimes they are fine. The cases where there is no underlining are correct, because I have only 4 books in the app at the moment.

What could be the problem now?



The second one has no period after the book code part, that is different to the rest. Also the numbers are not in normal reference numbers.

Do the missing book codes match a \toc3 or the Scripture Reference settings in Paratext?


I am unable to get any cross-references to come out with SAB. The footnotes are working fine.

I am also facing same problem about cross-references, some of cross references are working some of not in SAB 4.7. anybody know the solutions please?!

It is in the bug list for 4.7 as being caused by single verse references whereas verse ranges do appear.

If you have any data to show anything different, then please post it here.