New question from Apple about encryption for export compliance

When I wanted to add a build to my app update in App Store Connect, there was a warning about missing compliance:

@ChrisHubbard would you know how to answer this?

Wow, that is specific. We use an algorithm to obfuscate the contents added in the assets.

So the algorithm:

  • is not proprietary
  • is not accepted as standard by international standard bodies

So I would probably say it is the first one.


Thanks. Actually, it gets worse… When I select the first option, I get this:

They want to see documentation on it!

And there is more:

This seems to be the documentation from Apple:

Among other things it says: You can bypass these questions and streamline the submission process by providing the required information in your app’s Information Property List file.

Perhaps that is what’s needed in SAB apps?

I thought our use was exempt since we are not transmitting the encrypted data but just using it internally (for “copyright protection”). I will look further.

By the way, it was a build from a dictionary app that triggered it, actually. Built with DAB 11.0.4 Perhaps SAB apps don’t trigger this? I’ll give it a try to verify this…
I suppose I should have posted this here Dictionary App Builder - SIL Language Software Community

Yes, interestingly, I only get this problem with dictionary apps. I tried another one and I get this “Missing Compliance” warning next to the build.

When I tried a Scripture app just now, it didn’t even come up… Strange.

The questions have changes since we documented this (Scripture App Builder: Installing and Building Apps on Mac, Section 14). The questions used say that It was ok for us to use non-included encryption since it was “Limited to intellectual property and copyright protection” and I don’t see that in your questions anymore.

After further investigation, we conclude that we don’t include encryption functionality. We only decrypt assets. So you should answer the question before this one of whether the app uses encryption as NO.

So you might ask why you are getting this for a Dictionary app and not Scripture or Reading apps!

I looked in the Scripture and Reading Template app and we included the answer in the information property list (info.plist). But we didn’t in the Dictionary Template app. We will get this fixed!


Excellent, thank you!