Orphan paragraphs in diglot

I’m trying to print a diglot, but am ending up with orphan paragraphs. It seems like PTXprint is putting paragraphs side by side, rather than verses. In the example below the left project has a very long paragraph, whereas the right project has an additional paragraph marker, thus resulting in an orphan paragraph on the next page. Is there anything that can be done about it? (Other than changing the paratext file?)

This is the next page. I couldn’t put it into the original post, because new users cannot embed more than one file.

I believe it is pretty standard to have diglots balance at paragraph level. If a project is set up for verse style (each verse is a new paragraph - and this can be done in a change file) then each verse can match.

This is one consideration when choosing a diglot text - do the paragraphs match. If they are very different then it can raise questions for the reader as to why. The same would be true of other formats in the text like section heads, poetry, etc.

Another consideration (maybe more important) is how closely do the texts follow. Many of us who read English like to compare texts that differ (NASB / NLT for instance), but for many people seeing a text that differs significantly from a majority language text can be problematic and raise doubts as to the validity of the translation.

Generally I would advise teams that want/need to do diglot to use a text that matches or to adjust their text to match the diglot. This is obviously not a trivial matter since presumably the text has been formatted intentionally.

Thanks for your input, those are things worth considering.
For now I was just thinking of making something for personal use. How would I go about in creating such a change file? Is it quick and easy? Would I need to do that in Paratext or in PTXprint? I assume I would need to do the same for both projects. What do you do when the second project is being printed from a DBL bundle? How can you set that one up for verse style as well?

One option is to use the Advanced > Apply Changes Specified (PrintDraftChanges.txt) and add lines like the following:
The second to fifth lines must be modified to handle other paragraph markers that might proceed \v. This first puts a \m marker (you could change this to \p if desired) in front of every verse and then looks for a previous paragraph type marker and removes the extra \m.

“\\v” > “\\m \\v”
“\\p\s*\\m\s*\\v” > “\\p \\v”
“\\pi\s*\\m\s*\\v” > “\\pi \\v”
“\\q\s*\\m\s*\\v” > “\\q \\v”
“\\q1\s*\\m\s*\\v” > “\\q1 \\v”
“\\q2\s*\\m\s*\\v” > “\\q2 \\v”

This looks like a bug in the (python) merging program. It seems to be matching paragraph breaks without paying attention to verse numbers. There used to be a perl version that was a bit too clever for its own good, (let alone sanity of anyone trying to debug it) but as long as it wasn’t breaking horribly, it coped with this sort of thing.

We just added a check button on the diglot page “Alternate Merging” which is designed to improve the alignment for really badly synced texts. Yes, the merging aligns paragraphs. Both merge strategies start by aligning paragraphs that start the same verse. The default strategy then tries to align paragraphs of the same type within the misaligned subruns. I.e. it’s document centric. The alternate merging just aligns the whole block against the other whole block. You’ll possibly get some interesting alignments but it’ll probably be closer to what you expect in your case.

Thank you very much for your help. The result looks much better.