Recording in parts error

Hello!
I have used the “record in parts” tool a lot in the past. I recently updated my HT software after about a year from my last recording project. While trying to use the record in parts tool, I noticed it not functioning properly. I’ve attached a screen shot of what’s happening.
When I click on the tool, nothing pops up like usual. Instead I see the HT icon flash read in the task bar, and when I hover over it, it shows another HT window apparently open (which is the record in parts window) but it isn’t displayed anyway and when I click on it it doesn’t come up. Any help would be appreciated!
-Casey

Just a note:
I uninstalled version 3.3.8 and installed 3.3.7 and recording in parts worked just fine. I reinstalled 3.3.8, and it stopped working again.

This is very strange. There don’t appear to be any code changes between those two versions that could cause this. I just tried it in 3.3.8 on my computer and it displays just fine. Did you try it on multiple different blocks or just that one? I see that that block has a line break, but it looks as though that is probably just because you have the “Start new line at pause punctuation” option selected. I tried my version with a block that has a comma, and selecting that option does not seem to have any ill effects. It appears to be some kind of weird painting problem, but I’m really mystified. I wonder if it will just magically go away in version 4.0 (which I anticipate releasing soon). So far no one else has reported this.

I believe I tried different blocks of text with same result. I will check version 4 when it comes out :slight_smile: Till then, I guess I will just use 3.3.7.

Please let me know if the problem is happening in 3.4.0

I just checked it. I am still having the same error with version 3.4.0.
-Casey

Okay, thanks for checking. I’m not terribly surprised because I didn’t do anything to fix it in the new version. But then as far as I can tell, there’s also nothing in the previous version that should have caused the problem. It was just wishful thinking that it would magically go away. I guess I’ll need to have another look.

Thanks for following up! It would be nice to have things just ‘go away’ :slight_smile: Thanks for taking a peek. I’ll keep using 3.3.7 for now–the last version to work for me. Thanks.

I just looked again at the code and still don’t see any changes that could plausibly have this effect. Nor has anyone else reported it, so I am inclined to think that it is somehow particular to something happening on your computer that might just be coincidental to the version. Every other time I’ve thought this in my life, I’ve been wrong, but either way, I’m wondering if perhaps something is being written to the log that might indicate where the problem lies. Can you try it again in 3.4.0, open the Record in Parts dialog box, and then close HearThis. Then send the log (which can be found at %AppData%..\Local\Temp\SIL\HearThis\Log.txt) to me at tom_bogle@sil.org? If that doesn’t turn up anything helpful, the next step might be to check the fusion log. (I’ll send instructions for that if needed.)