Remove chapter # from header in Obadiah?

I have Show chapter numbers in single chapter books unchecked, but the spurious chapter number still appears in the running header for Obadiah. How can I prevent this?

Hmm. Is this monoglot or diglot? Diglot seems to have problems, it seems.

If monoglot… Can you try checking the ‘Show chapter numbers…’ box, print, uncheck it and print again? I think I just saw a chapter number before I did that but they’re not there now…

Ooops, I misread the question.
Mark/Martin have to add some extra logic to the python code turn off the chapter numbers in headers.
Until they’ve had time to fix the python code, then can use bookhooks, (in ptxprint-mods.tex): These are untested but ought to work:


If that works, then you can duplicate it for other 1-chapter book IDs in your publication, of course.

A fix for this problem has been committed.