SAB 4.7 Mac - an other plea for \m and \b in the footnote - but if \fp works, it will help us out as well

This is not a new issue … but needs be reported here again. We have lots of notes in 2 projects which have several alines of information and explanation. We may have over 500 of those in each project. It is not user-friendly to let the reader go through this without any ordering in parts.

We are not working in Paratext but thankful our system works fine with SAB.
I plead for a solution for this situation …

USFM does specify a \fp marker that is a footnote paragraph. The underlying standard can handle what you want.
If you are importing DOCX it is converted to USFM. You could export and edit the USFM to include the \fp marker.
If you can specify how your DOCX is marked up for paragraphs in Word footnotes you could ask for a feature request for \fp to be added to the DOCX conversion to USFM.

Indeed there is a \fp marker in the USFM manual but even with the addition of a hard return before it, it does not work in SAB 4.7.1. I tried several times. (VERY HARD :joy:)

Below how it looks like in in note:

\fp Als je jacht maakt op pythons voor een feestmaal, betekent het dat je ze levend moet vangen. Er zijn hier in Nieuw-Guinea geen koelkasten, geen manieren om voedsel goed te houden, en als een slang eenmaal dood is, bederft het vlees snel. De enige manier om het vlees vers te houden, is de slang in leven te houden.
\fp Jagen op pythons is een soort match voor de Folopa’s. Het is een wedstrijd, en vooral zo opwindend omdat de inzet hoog is. Ze praten graag over vroegere jachtpartijen en vertellen uitvoerig allerlei oude verhalen. Vooral over de keren dat het maar net goed ging. De python breekt je botten … zijn tanden zijn scherp, het lijken wel honderden naalden die allemaal naar achteren zijn gericht.
\fp etc.

Am I making a mistake in the notation or is here something wrong in SAB?

In the DOCX or DOC which I export to HTML we have no footnotes at the moment and we are glad with the display of these docs in the APP.

Thank you for your attention !

Would it be possible to help me out or should I report this as a bug, because the marker does not seem to work?!?

You did not make it clear if the \fp was in a footnote.
\f + \fr 1:1 \ft some text \fp some paragraph text \fp some more text in a para\f*

I included in a footnote in the above format and it was included but no new paragraph occured before the \fp text.

I’ve added this as a bug.

Sorry for the delay when I read it the first time I did not have time to test it.

1 Like

Thank you for checking and adding this as a bug.

This issue was added as bug during SAB version 4.7 on Nov. 18.
It has not been dealt with in version 4.7.1, the version we use now on MacOS Mojave
Will it be dealt with in version 5.0? We really need to have the \fp marker working in the FOOTNOTE and at the moment it does not work!

By the way we cannot get the APPs working any more in the Simulator …

@mcquayi, I made a pre-release build of 5.0 available to @joop. He said that the \fp worked but there is still an issue for him with the Simulator. I will attempt to take a look at that before we release 5.0.


@joop and anyone have trouble starting the Simulator, you can build and install a simulator build by doing the following:

  1. click on Run iOS App in Simulator button to open the dialog and just do Build.
  2. select the File -> Simulator Output Folder ... menu item
  3. start the Simulator by entering “Simulator” in Spotlight search (magnifying glass icon in menu bar)
  4. drag/drop the app from the Simulator Output Folder to the Simulator to install

This procedure works, though starting the Simulator (ad. 3) took 6-7 minutes even after a Restart of my Mac.

The resizing of text in the Simulator works fine in the bible text, but does not work at all in the footnote text!

Also I think article 1 should read like this:

  1. click on Run iOS App in Simulator button to open the dialog and just do Build . When finished close the Run iOS Simulator dialog box.

Glad it works, but speed is really a point of concern. I have an iMac 27" construction date late 2013 , 3.2 Ghz,IntelCore i5 with Mac OS Mojave 10.14.2

@joop, the Simulator comes with Xcode. We have no control over its performance. The Run iOS App in Simulator dialog is just there to make it slightly easier to interact with the Simulator.

If the Simulator is slow to start, then it is due to your computer. It could be the amount of free memory or speed of your hard drive (SSD is much faster than spinning disk). How much memory do you have? What type of disk do you have (HDD, Fusion Drive or SSD)?

I started the Simulator on a few Macs (all with High Sierra) that I have access to see the difference in start times:
My computer: 2017 iMac 3.4GHz Core i5 with SSD and plenty of memory = 25 seconds
Our Build Machine: 2014 Mac Mini 2.6GHz Core i5 with Fusion Drive and 8GB of memory = 35 seconds
Another Mac: 2014 Mac Mini 1.4GHz Core i5 with HDD and 4GB of memory = 5 1/2 minutes

FYI, every time you do Build iOS App it also builds the Simulator version of the app, but it requires that you have the iOS signing configuration correct. Doing the simulator build from the Run iOS App in Simulator is quicker and doesn’t require the iOS signing configuration.


Then it may have to with Mac OS Mojave!?

I have 8GB, should be ok - see your test on the minimac from 2014

There maybe a problem with the signing configuration for Mac, (I am still seeking a solution and I will give it an other try in the course of this month),
On the other hand in the past, it seems not to cause any problem.
Before Mojave and before SAB 4.7 or 4.7.1, it worked well enough and it was convenient to check my work this way.

I suggest somebody tries on Mojave … thank your for your explanation and I fully understand that you cannot control factors which are related to Xcode etc.