SAB 4.7 MAC Uploading to AppleStore Reconnect with Xcode

we reached the stage that we opened the Application Loader from Xcode and were able to complete the whole process of uploading the APP (IPA) to the App Store Connect.

When it was verified it we got the following series of error codes (see below) and we wonder how this comes, especially the fact that it looks like SIL is involved in signing the App, which is not the way it should be, is not it?

Are we doing something wrong or is here a bug in SAB or is it something in our signing iOS section in SAB where it looks like we did everything according to the manual …



ERROR ITMS-90035: “Invalid Signature. Invalid Info.plist (plist or signature have been modified). The file at path [] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose “Clean All” in Xcode, delete the “build” directory in the Finder, and rebuild your release target. For more information, please consult

ERROR ITMS-90159: “Invalid provisioning profile. This app contains an embedded provisioning profile that is not associated with your account. Please use a provisioning profile associated with Team ID YUJBX5NZX3.”

ERROR ITMS-90161: “Invalid Provisioning Profile. The provisioning profile included in the bundle OurBundleIdentifier [TemplateApp] is invalid. [Expired profile.] For more information, visit the iOS Developer Portal.”

ERROR ITMS-90046: “Invalid Code Signing Entitlements. Your application bundle’s signature contains code signing entitlements that are not supported on iOS. Specifically, value ‘’ for key ‘application-identifier’ in ‘Payload/’ is not supported. This value should be a string starting with your TEAMID, followed by a dot ‘.’, followed by the bundle identifier.”

ERROR ITMS-90334: “Invalid Code Signature Identifier. The identifier “org.sil.TemplateApp” in your code signature for “TemplateApp” must match its Bundle Identifier “OurBundleIdentifier””

ERROR ITMS-90443: “Invalid Provisioning Profile. The provisioning profile included in the bundle TemplateApp [Payload/] is invalid. [Expired code-signing certificate.] For more information, visit the iOS Developer Portal.”

WARNING ITMS-90722: “Certificate Expired. The signing certificate "C=US, O="Summer Institute of Linguistics, Inc (SIL )”, OU=3YE4W86L3G, CN=“iPhone Distribution: Summer Institute of Linguistics, Inc (SIL) (3YE4W86L3G)”, UID=3YE4W86L3G" with serial number 6059797938725678283 used to sign has expired. Learn more ("

I’d be double checking your provisioning profile information. If that all looks correct then let us know and one of the other guys might have more insight.

I did double check my provisioning profile, but I cannot find any mistake … but can I redo that process or will I be blocked?

My only thought is after you downloaded the provisioning profile, you did not pick that new one but one of the other ones you had created earlier.

I double checked , made some changes in the Keychain … removing old stuff and then worked with the right signing identity and the prov. profile file … but again the same error …
I have used the Xcode Application Loader but would not it be more logical, because the warning on top of the error list is about Xcode, that the problem is in Xcode, (although I do not fully understand the meaning of the error message and cannot find any clue in the menus of Xcode … a program which I in fact do not use … only because it is related to SAB) …
Does anybody have an idea how to overcome this bottleneck?

We had a similar issue to this that was caused by Fastlane not working properly or being installed.

Did you get your app working for inclusion in the App store?

We have now installed FASTLANE and I am not sure if it was installed before, but it might not have been installed.
We tried the same APP as in the past, but it still did not work.
We tried an other APP, a new one, and it worked. We wait for the outcome of the review (but that it is a different story). At the moment we have about 6 Apps. On the basis of this ‘first succes’ we are going to try the other ones and see if those also come through the checking. It is complicated but at least we are one significant step further.
Thanks for pointing to the Fastlane installation as a possible cause … even though I am not sure if that was the reason of the failures that we reported in the past.

Fastlane is the part that does the signing of the app. You error message showed that it had the wrong signature.

Thanks for the update, they help build bigger picture for everyone.

After all it was - as you said - some problem with the provisioning file.
The new prov. file I made today enabled me to pass the test and the App that has been waiting so long was uploaded today for the review by the App store.