SAB 6.2 build error

Just downloaded and installed the latest version.
During build encountered following problem:

1 error

Task :compileReleaseJavaWithJavac FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:compileReleaseJavaWithJavac’.

Compilation failed; see the compiler error output for details.

Help required please.

I said elsewhere:
If the release version is not created then recheck your passwords for the keystore. Most errors like that are keystore errors. Most likely the second password.

@Raja_Sand said:
checked that but error still persists…

Is the Keystore new? Have you used it successfully before?

The same keystore is being used previously.
Just downgraded to SAB 6.1 and tried to build the same app and it built successfully.

Do you have multiple version installed at once?

No, just downgraded to 6.1 for just testing.

I think I have pointed the main bug.

I just again upgraded from 6.1 to 6.2, after testing the same app in 6.1, and changed nothing and started the built process without changing anything and found the app built successfully.

After that added “Notification Icon” created through "Notification Icon Generator"and tried to rebuilt, the program has given that error.

So, I think, that Notification Icon is creating that problem.

Please have a look there.

I have reproduced the issue by adding a notification icon. I will take a look at it. Thanks for reporting!


Richard has made a fix. We will be rebuilding and re-releasing.

1 Like

Thanks a lot dear.
I was just expecting that.
Again thanks.

@Raja_Sand Thanks for testing and finding the issue so the developers knew where the problem was. That is an excellent example of problem solving for us all. And you saved me having to do the testing and refining. Much appreciated.

1 Like

Thanks dear

Always welcome.

Just updated the SAB to 6.2, the said problem has been resolved but found another bug, I am creating other post for that one.

Hope like this, the other bug will be fixed soon.