SAB 9.0 is not working on Windows 10

Hi there
Did anyone encounter failure SAB 9.0 failure on Windows 10? It looks the Gradle Daemon incompatible? See attached screenshot. Welcome any feedback. thanks

Mind

Have you updated the Android SDK?
You should see something like this in settings:
image

You should have the latest ZULU OpenJDK 8 installed:
https://www.azul.com/downloads/zulu-community/?version=java-8-lts&os=windows&package=jdk-fx

and install the latest Android SDK from the menu.
image

Install to c:\android-sdk if that is where it was installed before.

Go back to settings and click “Install Packages…”
image

Hi Greg

I’ve already installed Android SDK packages, Java Development Kit, but unable to build apk, with screenshot below

1

@Mind2_Spirit
Try building a basic test project and see if you get the same error.

I have found that sometimes a project that was built with older version of SAB might have certain issues (as the project file may have some changes to the structure/requirements or something like that, I think?). I that case, I rebuild the project from scratch.

Hi
I’ve started a new project to compile but still hits the same error. Wonder I need to rebuild the windows OS or not…

Thanks for your feedback anyway.

Try installing the SDK tools at c:\android-sdk and changing the path for Android SDK Location to there.

Also, go through the installation instructions carefully, step by step:

The error messages you are getting (“package in inconsistent location”) indicate that there are some issues with the Android SDK installation. You could try deleting the entire c:\sdk folder and then clicking ‘Install Android SDK’ to take you through the process of downloading and reinstalling the Android SDK.

1 Like

Hi

I’ve reinstalled with new android sdk path also failed… Thank you everyone.
I gotta give up and install on Mac….

Hopefully the reinstall of the Android SDK will have eliminated some of the errors you were getting before. Please can you repost the screenshot of the errors you are now getting. This can help us work out what else might need to be resolved. Thanks.

Hi, i’ve rebuilt Android SDK with a brand new folder, e.g. ‘Android-sdk’ , previously ‘sdk’

The first screenshot here showed everything normal (Follow installation guide 2.3.1, with Android SDK packages from internet)
Android SDK setting

Once i tried to “Build Android App”, it showed some “inconsistent location”, see highlighted green

The expected path didn’t exist (e.g. c:\android\sdk\platforms\android-30)
Screenshot 2021-08-13 133614

So any bat file which i can change the above path for building the apk?
C:\android-sdk\platforms\android-11 was generated automatically which i can’t customize during my installation. I suspect that’s the reason for failing to proceed.

Thanks

To resolve this issue, please rename the folder android-11 with the name android-30.

I will take a look at the code again to work out why this is not happening automatically.

Hi Richard, thanks, it works !!!

1 Like