SAB 9.1.1 Build error

Dear Team Members,

Today I have created one project in SAB 9.1.1. when I build app option it gives me error. Please find below.

Does anyone know about this issue kindly give me your direction.

Thank you


I also had problem with the version 9.1.1. The error message was about audio clips built into the app. So, I had to revert back to 9.1. I am waiting for a fix for this issue.


@C_Thiyagarajan The error you are getting indicates that the Android SDK installation is not complete. Please go to the Settings > Android SDK tab and click the Install Packages button.

@Bayar_Garam If you are getting a message about audio clips, this is different from the error that @C_Thiyagarajan is getting. Please post the message, so we can see what it is. Thanks.

Thank you Richard for you reply. I have followed your instructions and updated.


Then I try to build a app it gives me error

The message right at the top of the command window indicates that there is a problem with the Android SDK folder names. You need to do one of the following:

  1. Change the name of the “c:\sdk\platforms\android-11” folder to “c:\sdk\platforms\android-30”.


  1. Delete your Android SDK folder and try installing it again.

Thanks richard, I followed both the instructions still I am facing same issue.

  1. image



Please check that it is installed to c:\sdk otherwise change the Android SDK Location to match the path where it is installed. Use the Browse button.

Thanks GregAshleyCooper for responded this issue. I’ve changed location into d:\sdk still I am facing same issue.

Does the c:\sdk\platforms\android-30 folder exist?

Thanks richard for your replay. It is there in the sdk folder. Today tried again it is now SAB builds app. But I could not install my android 11 phone.

(App not installed)

Good to hear that the build process completed. I see that you have created several versions of the APK file. Each is for a specific phone architecture. If you try and install the wrong one it will not install.

For most Android phones, you will need either the universal APK file BSI_Bible.0.0.1.apk or the ARM-64 one: BSI_Bible-0.0.1-arm-64.apk.

Hi richard I tried both apk files still giving same error. I found that allready I have installed previous version in my phone. So I couldn’t install over it and uninstalled the old one and then I install new one. Now it is working.

Thank you so much for all your support.

Great to hear that it is working!

I didn’t even know there was an option.

Many users of SAB will not see the option of creating multiple APKs. The choice will appear on the App > APK tab if you are using either Crosswalk (used for complex fonts) or the FFmpeg libraries (used for creating audio and video clips). Since both these libraries are quite large and are phone-architecture specific, it might be better to create multiple (smaller) APKs, one for each phone architecture, rather than trying to include all libraries in a single APK.

But having said all that, since Google has now moved to using Android App Bundles (AAB), you no longer need to upload multiple APKs to Google Play. Google will serve users with just the libraries and resources they need for their specific type of phone.

1 Like

Sorry for being slow in responding. Since the error I get is different, I will start a new post for that.