Seemingly "Random" blank space at bottom of some pages

PtxPrint is leaving significant white at the bottom of some pages for the config (Luke1-9). User is needing to print this week!

SFM file doesn’t have any markers at the white space location

Changes to layout config/numbers moves the space to different pages but I cannot get rid of the extra white space.

I’ve seen that a lot. Sometimes the next page has a picture that wouldn’t fit on the current page, but other times there’s no obvious reason for it. In my case I was just testing, not preparing for actual publication, so it didn’t matter. But in “real life” it would be a problem.

This is a common problem, so it’s worth a bit of an explanation.

By default the Layout Page Unbalanced Lines is set to 0. This means that the column balancer must keep removing content from the page until it can get a perfect balance. An additional requirement is that a paragraph of more than 1 line must not break with less than 2 lines on a page.
Could the page balancer add a line to the first column and the second? To do that it would need to pull 2 lines from the next page. But the next page starts with a split 5 line paragraph. But you can’t split those 3 lines on the next page. And so we get the page break we have.
So what to do?
There are two options:

  1. If you want perfect balancing it is necessary to adjust some paragraph lengths. This is what a typesetter spends their time doing when they talk about page balancing. This is done using adjustment files.
  2. If you are willing to allow a few imperfections, one could increase the unbalanced lines. The balancer will not allow a column to be more unbalanced than the setting. But it will also try to minimise the unbalancing so setting a high value doesn’t necessarily result in lots of unbalanced lines.

I would be interested in knowing which of these strategies you would prefer to use (even if time and experience forces you to use option 2).

I would be interested in being able to modify the unbalanced line setting, it might be more palatable the 30% of the page being blank.

Layout tab/page then on the right under the two columns find the unbalanced lines setting. Pick a number and hit print :slight_smile:

Given that this is a topic that comes up regularly, and causes a lot of frustration for users who want it “just right” I have finally created a couple of training videos on this topic:

Both videos achieve roughly the same outcome (typesetting and balancing the book of Mark), but each uses a different technique. (a) is easy to get started but leaves you with less options going forward; (b) is a bit more difficult to get started, but ends up with a much more refined look due to having far more control.

There are “chapter breaks” marked, so it is easy to skip through to the next block, and you don’t really need to watch right to the end of each video. Happy typesetting…

2 Likes

Both were very helpful! Thank you!