"To download audio files, please connect to the internet"

I am having my first go at building an app with SAB (Version 8.6).

I have never been able to get audio to play in the app. I have it said to download from the Internet, and I have the files hosted online.

What I expected: when I hit the play button in the app, it begins playing the audio for the current chapter.
What I saw instead: a popup box says “To download audio files, please connect to the internet.”

Things I tried:

  1. I thought that perhaps this was a permissions problem - the only permission that I can toggle is for storage, and I have permitted storage.
  2. Testing in the PWA – it works – both locally and when I upload the PWA to a server. The audio works as expected.
  3. Installing the app over USB from SAB, and also by downloading and installing the apk separately.

Any ideas?

I have seen this come back intermittently as I have worked on developing a new app. At least once, I was able to restart my phone and the behavior ceased. I’m not sure what to make of that, but perhaps it is a problem on my own phone?

I wanted to add that I have had this happen as well.

I had a user tell me this happened to him, even though I hadn’t had any problems on any of my physical test devices. Then just recently, I’m having this problem come up again when using a virtual Pixel 2 emulator on Android Studio.

Unfortunately I don’t have a solution yet.

I will be curious to see if a reboot always allows it to work or not.

Could you ask the user to restart their phone?

Hi hope1.

Sorry about the delay. I was trying to troubleshoot because I had another issue in that a specific Script wasn’t showing up correctly that was added as another book. I was able to correct it by removing the book collection and adding it again.

About the audio, though, I found a solution that worked for me so far. I’m not sure if it’s a change with the newer version or not, but I found following what Matt_A described in his post to be a fix for my audio not downloading:

The audio source had to be specified for each book. A global setting was not enough.

Not sure if it will work for you, but it got my audio working again. I download them from archive.org.