Modern PWA displays "sometimes" (SAB v11.3 and 11.4.1)

Hi,
The Modern PWAs display inconsistently for us. Sometimes the Modern PWA will display reasonably quick, sometimes we get a spinning circle for a long time, sometimes we get a blank screen.

I have disabled all Chrome extensions except “Clear Site Data”.

If we get a spinning circle, and we delete the cookies (or use the Clear Site Data extension), it usually displays properly on reload, but it won’t work consistently when you return to that PWA page again.

I have checked for extra fonts and am using the “Latest from the Repository” option.

When it spins for a long time, I see this error in the Inspect>Console view on Chrome:
Screenshot 2024-05-24 130854

I see similar things with both Scriptoria builds (v11.3) and my local builds (v11.4.1).

Thanks, Mike (@samuel , @Jongjin_Jeong )

This error was seen, when the PWA dislpay was blank.

I am assisting with SAB class at EMDC and will not have time to look at this in the near future. I might have time next week.

Chris

1 Like

FWIW - I’m seeing the same thing. So much so, we (Kalaam/IPS Apps) are not replacing our old PWA option with the new one in most cases.

1 Like

Here are 3 of our pages with the Modern PWA:
https://media.ipsapps.org/aph/osa/bible/
https://media.ipsapps.org/bmj/osa/bible/
https://media.ipsapps.org/tdg/osa/bible/

I believe I have fixed the issue with the failure displayed in the first message above. It was trying to use the saved last reference which would be specific to the project.

Now, I only use it if the same package is run. Try using the latest source from the repository and switching between projects.

Chris

1 Like

Thanks, I’ll test it!

The spinning circle appears to be fixed. Thanks!
We still get a blank page, when we switch back and forth between them.
Screenshot below, it is the same error in the console each time.
Sometimes a refresh (CTL-SHFT-R) will fix it, but not always.
image

The error happens more regularly when I start on the webpage containing the PWA in a window.
https://nepalmatribhasha.org/en/athpahariya-online-bible
https://nepalmatribhasha.org/en/bote-online-bible
https://nepalmatribhasha.org/en/tamang-western-online-bible

Sorry, that screenshot is too hard to read.

Chris