Test Modern PWA

Dear Team,
I tried to test a modern PWA on a local web server, and got the following windows.


image

Could you please tell me, why I can’t get the right APP display?

Thanks in advance!
Andy

Hi Andy,
I don’t know if this will help, but I experienced something similar and found it was because I had not started the required string with the “/”. I had used something like: aks/osa/bible/web/rut and it should have been /aks/osa/bible/web/rut. I’m referring to this part of the SAB build process.

Hope that helps.

Hi Dan_Neville,
Thanks for your advice!
I have checked it with “/”, but it still does not work.

Andy

Can you right-click on the page and choose inspect. There will be another windows with tabs along the top. Take a look at the console tab. Is there is an exception?

Chris

Hi Chris,
I have checked it. Yes, there was an exception.

Andy

I’m having the exact same behavior. Here is what my console is reporting:

BTW, I am using the Fork path that was suggested we use to get the latest PWA build process.

@david_coward, Try using the Clear Site Data Extension to clear the data for http://localhost:4173.

Chris

@Andy, thank you for sending you project. I found the problem. There was an extra font listed in the font choices for the book collection or book that wasn’t in the list of fonts for the app (it probably got deleted at some point). To me, this seems to be a bug in the SAB desktop app that doesn’t clean these up when a font is deleted.

The native app ignores these entries so I changes the PWA to do the same. If you use the latest PWA source code (see Using latest PWA source code), then your app should work (it did for me).

Chris

Hi Chris, Many thanks! It also works for me now.
Andy

We are facing this problem.
Can you support please to resolve the issue…

Thanks in anticipation

@Raja_Sand This is a solved issue. If you have a problem, you should create a new post.